Составить программу в Pascal, которая вводит строку символов, удаляя все символы, не являющиеся
латинскими буквами и затем выводит результаты.Ответы на вопрос
var
s: string;
i,k: integer;
begin
readln(s);
i:=1;
k:=length(s);
while i<>k do
begin
k:=length(s);
if (upcase(s[i]) < 'A') or (upcase(s[i]) > 'Z') then
begin
delete(s, i, 1);
i:=i-1;
end;
i:=i+1;
end;
writeln(s);
end.
Пример ввода:
Gleb1Kosyrev Sample Текст, Pointer Symbol is ^
Пример вывода:
GlebKosyrevSamplePointerSymbolis
Программа на Pascal, которая вводит строку символов, удаляет все символы, не являющиеся латинскими буквами и затем выводит результаты, может выглядеть следующим образом:
```pascal program RemoveNonLatinChars; uses crt;
var inputString, resultString: string; i: integer;
begin clrscr; writeln('Введите строку символов:'); readln(inputString);
resultString := '';
for i := 1 to length(inputString) do begin if (inputString[i] in ['a'..'z']) or (inputString[i] in ['A'..'Z']) then resultString := resultString + inputString[i]; end;
writeln('Результат:'); writeln(resultString);
end. ```
Эта программа начинается с объявления переменных `inputString` и `resultString`, а также переменной `i` для использования в цикле. Затем программа запрашивает у пользователя ввести строку символов и сохраняет ее в переменную `inputString`.
Далее программа создает пустую строку `resultString`, которая будет использоваться для хранения результата.
Затем программа начинает перебирать каждый символ в `inputString` с помощью цикла `for`. Если текущий символ является латинской буквой (проверяется с помощью операторов `in ['a'..'z']` и `in ['A'..'Z']`), то он добавляется к `resultString`.
После завершения цикла программа выводит результат, содержащий только латинские буквы, на экран.
Эта программа позволяет вводить любую строку символов и удаляет все символы, не являющиеся латинскими буквами, затем выводит результат на экран.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
