Вопрос задан 29.07.2018 в 01:15. Предмет Информатика. Спрашивает Савчук Вася.

1)Написать на языке Паскаль программу ввода четырёх целых чисел и вычисления их среднего

арифметического. 2)Вводятся величины X,Y целого типа. Написать программу для обмена значений величин. Необходимо использовать вспомогательную величину Т. Протестировать программу для X=5 и Y=-11. 3)Написать программу для вычисления дискриминанта d квадратного уравнения ax2 + bx + c = 0. 4)Дан размер файла в байтах. Используя операцию деления нацело, найти количество полных килобайтов, которые занимает данный файл (1 килобайт = 1024 байта). 5)Дано двузначное число. Найти сумму и произведение его цифр. Помогите, пожалуйста. Ничего не понимаю по этому паскалю
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ласкунов Сергей.
1) Сейчас сделаю остальное.
Program arifm;Var a, b, c, d, ar:real;beginwriteln('Введите первое число');readln(a);writeln('Введите второе число');readln(b);writeln('Введите третье число');readln(c);writeln('Введите четвертое число');readln(d);ar:=(a+b+c+d)/4;writeln('Ответ:',ar);end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

1) Программа для вычисления среднего арифметического четырех целых чисел на языке Паскаль:

```pascal program AverageCalculation;

var num1, num2, num3, num4: integer; average: real;

begin writeln('Введите четыре целых числа:'); readln(num1, num2, num3, num4); average := (num1 + num2 + num3 + num4) / 4; writeln('Среднее арифметическое: ', average:0:2); end. ```

Объяснение: - В этой программе мы объявляем четыре переменные типа `integer` для хранения введенных чисел и переменную `average` типа `real` для хранения среднего арифметического. - Пользователю предлагается ввести четыре целых числа с помощью `readln`. - Затем мы вычисляем среднее арифметическое, складывая все введенные числа и деля сумму на 4. - Наконец, выводим результат с помощью `writeln`.

2) Программа для обмена значениями двух переменных на языке Паскаль:

```pascal program ValueExchange;

var X, Y, T: integer;

begin writeln('Введите значения X и Y:'); readln(X, Y); T := X; X := Y; Y := T; writeln('После обмена:'); writeln('X = ', X); writeln('Y = ', Y); end. ```

Объяснение: - В этой программе мы объявляем три переменные типа `integer` для хранения значений X, Y и временной переменной T. - Пользователю предлагается ввести значения X и Y с помощью `readln`. - Затем мы сохраняем значение X во временной переменной T. - Значение Y присваивается переменной X. - Значение T присваивается переменной Y. - Наконец, выводим результат с помощью `writeln`.

3) Программа для вычисления дискриминанта квадратного уравнения на языке Паскаль:

```pascal program DiscriminantCalculation;

var a, b, c, d: real;

begin writeln('Введите коэффициенты a, b и c:'); readln(a, b, c); d := b * b - 4 * a * c; writeln('Дискриминант: ', d:0:2); end. ```

Объяснение: - В этой программе мы объявляем четыре переменные типа `real` для хранения коэффициентов a, b, c и дискриминанта d. - Пользователю предлагается ввести значения коэффициентов a, b и c с помощью `readln`. - Затем мы вычисляем дискриминант по формуле `d = b * b - 4 * a * c`. - Наконец, выводим результат с помощью `writeln`.

4) Программа для вычисления количества полных килобайтов в файле на языке Паскаль:

```pascal program FileSizeCalculation;

var fileSizeInBytes, fileSizeInKilobytes: integer;

begin writeln('Введите размер файла в байтах:'); readln(fileSizeInBytes); fileSizeInKilobytes := fileSizeInBytes div 1024; writeln('Количество полных килобайтов: ', fileSizeInKilobytes); end. ```

Объяснение: - В этой программе мы объявляем две переменные типа `integer` для хранения размера файла в байтах и размера файла в килобайтах. - Пользователю предлагается ввести размер файла в байтах с помощью `readln`. - Затем мы используем операцию деления нацело (`div`) для вычисления количества полных килобайтов, которые занимает данный файл. - Наконец, выводим результат с помощью `writeln`.

5) Программа для вычисления суммы и произведения цифр двузначного числа на языке Паскаль:

```pascal program DigitCalculation;

var number, digit1, digit2, sum, product: integer;

begin writeln('Введите двузначное число:'); readln(number); digit1 := number div 10; digit2 := number mod 10; sum := digit1 + digit2; product := digit1 * digit2; writeln('Сумма цифр: ', sum); writeln('Произведение цифр: ', product); end. ```

Объяснение: - В этой программе мы объявляем пять переменных типа `integer` для хранения введенного числа, его цифр, суммы и произведения цифр. - Пользователю предлагается ввести двузначное число с помощью `readln`. - Затем мы используем операции деления нацело (`div`) и взятия остатка от деления (`mod`) для выделения цифр числа. - Вычисляем сумму и произведение цифр. - Наконец, выводим результат с помощью `writeln`.

Надеюсь, это поможет вам разобраться с программированием на языке Паскаль! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос