
PascalABC.NET Составьте программу заполнения массива а [1..10] числами Фибоначчи. В
последовательности Фибоначчи первый элемент равен нулю ,второй — единице, а каждый элемент, начиная с третьего, равен сумме двух предыдущих.

Ответы на вопрос

var
a:array [1..10] of integer;
i:integer;
begin
a[1]:=0;a[2]:=1;
write(a[1],a[2]:4);
for i:=3 to 10 do
begin
a[i]:=a[i-2]+a[i-1];
write(a[i]:4);
end;
end.
Если моё решение помогло вам, пометьте его лучшим. Спасибо!



Программа на PascalABC.NET для заполнения массива числами Фибоначчи
```pascal program FibonacciArray;
var a: array[1..10] of Integer; i: Integer;
begin a[1] := 0; // первый элемент равен нулю a[2] := 1; // второй элемент равен единице
for i := 3 to 10 do a[i] := a[i-1] + a[i-2]; // каждый элемент равен сумме двух предыдущих
// выводим массив на экран for i := 1 to 10 do WriteLn(a[i]);
end. ```
В данной программе мы объявляем массив `a` размером 10 элементов типа `Integer`. Затем мы инициализируем первые два элемента массива значениями 0 и 1, соответственно. Далее, с помощью цикла `for`, мы заполняем остальные элементы массива значениями, равными сумме двух предыдущих элементов. В конце программы мы выводим массив на экран с помощью цикла `for` и процедуры `WriteLn`.
Таким образом, после выполнения программы, массив `a` будет содержать числа Фибоначчи от 0 до 34.
Примечание: Данная программа написана на языке PascalABC.NET. PascalABC.NET - это среда разработки, которая поддерживает язык программирования Pascal и имеет синтаксические расширения по сравнению с классическим Pascal.
Надеюсь, эта информация будет полезной! Если у вас возникнут еще вопросы, не стесняйтесь задавать.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili