
Написать программу в Pascal ABC. Последовательность чисел заканчивающихся на 0(ноль). Необходимо
найти количество чисел у которых количество десятков "4" или "6".

Ответы на вопрос

var
n,k,d:integer;
begin
k:=0;
repeat
Write('Введите натуральное число, 0- завершить: ');
Read(n);
if n>0 then begin
d:=(n mod 100) div 10;
if (d=4) or (d=6) then Inc(k)
end
until n=0;
Writeln('Искомых чисел - ',k)
end.
Тестовое решение:
Введите натуральное число, 0- завершить: 345
Введите натуральное число, 0- завершить: 6285
Введите натуральное число, 0- завершить: 7854
Введите натуральное число, 0- завершить: 1324
Введите натуральное число, 0- завершить: 653
Введите натуральное число, 0- завершить: 66666
Введите натуральное число, 0- завершить: 0
Искомых чисел - 2



var a, b, c, d:integer;
begin
read (a);
if a mod 10 = 0 then writeln ('число оканчивается на ноль')
else writeln ('число оканчивается не на ноль');
end. – программа, которая высчитывает, оканчивается ли число на ноль или нет. Принцип работы:
ты вводишь число. Если число делится на 10, тогда на экран тебе выводится подтверждающая этому информация, что число оканчивается на ноль.
program random;
var a, b:integer;
begin
read (a, b); // a – десятки, b – единицы
if a = 4 or 6 then writeln ('число имеет в себе 4 десятка')
end. – программа, которая говорит тебе, имеет ли число в себе 4 или 6 десятков. Принцип работы:
ты вводишь 2 переменные: a и b; a — это десятки, а b — единицы. Если число a (десятки) равно четырём или шести, тогда на экран тебе выводится информация, подтверждающая это.



Программа на Pascal ABC для подсчета чисел с количеством десятков "4" или "6"
```pascal program CountNumbers;
var num, count: integer;
begin count := 0; repeat write('Введите число (0 для завершения): '); readln(num); if (num mod 10 = 4) or (num mod 10 = 6) then count := count + 1; until num = 0; writeln('Количество чисел с количеством десятков "4" или "6": ', count); end. ```
Объяснение программы
1. Программа начинается с объявления переменных `num` и `count`. Переменная `num` будет использоваться для ввода чисел, а переменная `count` будет использоваться для подсчета чисел с количеством десятков "4" или "6". 2. Затем идет блок `begin...end`, в котором выполняется основная логика программы. 3. Сначала переменной `count` присваивается значение 0. 4. Затем используется цикл `repeat...until`, который будет выполняться до тех пор, пока пользователь не введет число 0. 5. Внутри цикла пользователю предлагается ввести число с помощью `write` и `readln`. 6. Затем проверяется, заканчивается ли введенное число на "4" или "6" с помощью условия `(num mod 10 = 4) or (num mod 10 = 6)`. Если условие выполняется, то к переменной `count` добавляется 1. 7. Цикл повторяется до тех пор, пока пользователь не введет число 0. 8. После завершения цикла выводится сообщение о количестве чисел с количеством десятков "4" или "6" с помощью `writeln`.
Пример работы программы
``` Введите число (0 для завершения): 123 Введите число (0 для завершения): 456 Введите число (0 для завершения): 789 Введите число (0 для завершения): 246 Введите число (0 для завершения): 0 Количество чисел с количеством десятков "4" или "6": 2 ```
В данном примере программа считает количество чисел, введенных пользователем, у которых количество десятков равно "4" или "6". В данном случае, из введенных чисел (123, 456, 789, 246), только числа 456 и 246 удовлетворяют условию, поэтому результатом работы программы будет число 2.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili