
Помогите написать прогу! PASCAL 1)Пусть a=17, b=5. Найти div, mod и sgr(b) 2)Пусть a=48, b=6.
Найти div, mod и sgr(а) 3)Пусть a=25, b=7. Найти div, mod,sgr(b) и sgrt (a)

Ответы на вопрос

begin
a:=17; b:=5;
writeln(a div b,' ',a mod b,' ',sqr(b));
a:=48; b:=6;
writeln(a div b,' ',a mod b,' ',sqr(a));
a:=25; b:=7;
writeln(a div b,' ',a mod b,' ',sqr(b),' ',sqrt(a));
end.
Результат:
3 2 25
8 0 2304
3 4 49 5



1) Найти div, mod и sgr(b), где a = 17 и b = 5
Для того чтобы найти div и mod, мы можем использовать операторы div и mod в языке Pascal. Оператор div выполняет целочисленное деление, возвращая только целую часть результата, а оператор mod выполняет операцию взятия остатка от деления.
Вот код на Pascal, который выполняет эти вычисления: ```pascal program Example; var a, b, resultDiv, resultMod: Integer; begin a := 17; b := 5; resultDiv := a div b; // Вычисляем целочисленное деление resultMod := a mod b; // Вычисляем остаток от деления writeln('div: ', resultDiv); writeln('mod: ', resultMod); // Функция sgr(b) возвращает знак числа b (-1, если b < 0, 0, если b = 0, и 1, если b > 0) if b < 0 then writeln('sgr(b): -1') else if b = 0 then writeln('sgr(b): 0') else writeln('sgr(b): 1'); end. ```
В результате выполнения этого кода, вы увидите следующий вывод: ``` div: 3 mod: 2 sgr(b): 1 ``` Здесь мы получаем результаты div = 3, mod = 2 и sgr(b) = 1 для a = 17 и b = 5.
2) Найти div, mod и sgr(a), где a = 48 и b = 6
Аналогично предыдущему примеру, мы можем использовать операторы div и mod для выполнения целочисленного деления и вычисления остатка от деления. Также, чтобы найти sgr(a), мы можем использовать условные операторы для определения знака числа a.
Вот код на Pascal, который выполняет эти вычисления: ```pascal program Example; var a, b, resultDiv, resultMod: Integer; begin a := 48; b := 6; resultDiv := a div b; // Вычисляем целочисленное деление resultMod := a mod b; // Вычисляем остаток от деления writeln('div: ', resultDiv); writeln('mod: ', resultMod); // Функция sgr(a) возвращает знак числа a (-1, если a < 0, 0, если a = 0, и 1, если a > 0) if a < 0 then writeln('sgr(a): -1') else if a = 0 then writeln('sgr(a): 0') else writeln('sgr(a): 1'); end. ```
В результате выполнения этого кода, вы увидите следующий вывод: ``` div: 8 mod: 0 sgr(a): 1 ``` Здесь мы получаем результаты div = 8, mod = 0 и sgr(a) = 1 для a = 48 и b = 6.
3) Найти div, mod, sgr(b) и sgrt(a), где a = 25 и b = 7
Для вычисления div и mod, мы можем использовать операторы div и mod, как и ранее. Для вычисления sgr(b) и sgrt(a), мы можем использовать условные операторы для определения знаков чисел b и a соответственно.
Вот код на Pascal, который выполняет эти вычисления: ```pascal program Example; var a, b, resultDiv, resultMod: Integer; begin a := 25; b := 7; resultDiv := a div b; // Вычисляем целочисленное деление resultMod := a mod b; // Вычисляем остаток от деления writeln('div: ', resultDiv); writeln('mod: ', resultMod); // Функция sgr(b) возвращает знак числа b (-1, если b < 0, 0, если b = 0, и 1, если b > 0) if b < 0 then writeln('sgr(b): -1') else if b = 0 then writeln('sgr(b): 0') else writeln('sgr(b): 1'); // Функция sgrt(a) возвращает знак квадратного корня из числа a (-1, если a < 0, 0, если a = 0, и 1, если a > 0) if a < 0 then writeln('sgrt(a): -1') else if a = 0 then writeln('sgrt(a): 0') else writeln('sgrt(a): 1'); end. ```
В результате выполнения этого кода, вы увидите следующий вывод: ``` div: 3 mod: 4 sgr(b): 1 sgrt(a): 1 ``` Здесь мы получаем результаты div = 3, mod = 4, sgr(b) = 1 и sgrt(a) = 1 для a = 25 и b = 7.
Надеюсь, это поможет вам написать программу на Pascal для решения данных задач! Если у вас возникнут еще вопросы, не стесняйтесь спрашивать!


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili