Пожалуйста напишите программы для заданий для питона Задание 1 Найдите, сколько килограммов яблок
собрали ученики. Со- ставьте программу и рассчитайте. Ученики 5 класса собрали N кг яблок, а ученики 6 класса на S кг яблок меньше. Сколько всего килограммов яблок собра- ли оба класса? Задание 2 Найдите периметр и площадь кабинета информатики. Пусть ширина кабинета бу- дет а метров, а длина b метров. b метр а метр Задание 3 Составьте программу, которая запрашивает у пользовател имя, возраст, номер телефона: имя ("Как вас зовут?") возраст ("Сколько вам ле "") номер телефона ("Како вас номер телефона?") В результате программы должны выйти три строки: "Имя" "Возраст" "Номер телефона"Ответы на вопрос
Ответ:
1. var
N,a,b:integer;
begin
a:=N;
b:=N-8;
readln(a);
write(a+b);
end.
2. var
S,P, a,b:integer;
begin
read(a);
read (b);
begin
P:=(a+b)*2;
write('Периметр:',P); end;
begin
S:=a*b; write('Площадь:',S); end;
end.
3. var
a,b,c:string;
begin
write('Как вас зовут?');
readln(a);
write('Сколько вам лет?');
readln (b);
write('Какой у вас номер телефона?');
readln (c);
write('Имя:',a);
write('Возраст:',b);
write('Номер телефона:',c);
end.
Объяснение:
вот Матвей
Конечно, вот программы для выполнения указанных заданий на Python:
Задание 1: Найдите, сколько килограммов яблок собрали ученики. Составьте программу и рассчитайте. Ученики 5 класса собрали N кг яблок, а ученики 6 класса на S кг яблок меньше. Сколько всего килограммов яблок собрали оба класса?
```python # Ввод данных N = float(input("Введите количество килограммов яблок учеников 5 класса: ")) S = float(input("Введите разницу в килограммах для 6 класса: "))
# Вычисление общего количества яблок total_apples = N + (N - S)
# Вывод результата print(f"Общее количество собранных яблок: {total_apples} кг") ```
Задание 2: Найдите периметр и площадь кабинета информатики. Пусть ширина кабинета будет a метров, а длина b метров.
```python # Ввод данных a = float(input("Введите ширину кабинета в метрах: ")) b = float(input("Введите длину кабинета в метрах: "))
# Вычисление периметра и площади perimeter = 2 * (a + b) area = a * b
# Вывод результата print(f"Периметр кабинета: {perimeter} метров") print(f"Площадь кабинета: {area} квадратных метров") ```
Задание 3: Составьте программу, которая запрашивает у пользователя имя, возраст и номер телефона, и выводит эти данные на экран.
```python # Запрос данных у пользователя name = input("Как вас зовут? ") age = input("Сколько вам лет? ") phone_number = input("Какой у вас номер телефона? ")
# Вывод данных на экран print("Имя:", name) print("Возраст:", age) print("Номер телефона:", phone_number) ```
Теперь у вас есть программы для выполнения указанных заданий на Python.
Задание 1:
```python N = float(input("Сколько килограммов яблок собрали ученики 5 класса? ")) S = float(input("Сколько килограммов яблок собрали ученики 6 класса меньше? "))
total = N + S print("Общее количество килограммов яблок, собранных обоими классами:", total) ```
Задание 2:
```python a = float(input("Введите ширину кабинета информатики в метрах: ")) b = float(input("Введите длину кабинета информатики в метрах: "))
perimeter = 2 * (a + b) area = a * b
print("Периметр кабинета информатики:", perimeter, "м") print("Площадь кабинета информатики:", area, "м²") ```
Задание 3:
```python name = input("Как вас зовут? ") age = input("Сколько вам лет? ") phone_number = input("Какой у вас номер телефона? ")
print("Имя:", name) print("Возраст:", age) print("Номер телефона:", phone_number) ```
В этих программах используется функция `input()`, которая позволяет пользователю вводить данные с клавиатуры. Введенные значения сохраняются в переменных и используются для выполнения вычислений или вывода результатов.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
