Вопрос задан 03.11.2023 в 15:37. Предмет Информатика. Спрашивает Стрисюк Віталіна.

Даю 35 балов!!! Решить на питоне! Строки до пустой: Пользователь вводит строки одну за другой до

тех пор, пока не введёт пустую. Программа должна выводить введенные строки, пока не встретилась пустая. Формат ввода: Вводятся строки одна за другой. Формат вывода: Введенные строки до пустой Только мне не нада писать вот это! Это не работает. Прежде чем сдать посмотрите работает ли прога!!! 1 2 3 4 5 6 7 8 9 10 >>> while x:=input():print(x) ... 1 1 2 2 3 3 >>> работает для питона 3.8+ НЕ НАДО МНЕ ПРИСЫЛАТЬ ВОТ ЭТО!!!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Krylova Sofya.

while True:

   x = input()

   print(x)

   if x == "":

       break

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи на языке Python можно использовать цикл while. Внутри цикла будет выполняться чтение ввода пользователя с помощью функции input() и вывод строки на экран.

Вот пример кода, решающего данную задачу:

```python lines = [] line = input("Введите строку: ") while line: lines.append(line) line = input("Введите строку: ")

for line in lines: print(line) ```

В данном примере ввод пользователя происходит внутри цикла while, пока пользователь не введет пустую строку. Введенные строки сохраняются в списке lines. Затем происходит вывод всех введенных строк на экран с помощью цикла for.

Пример работы программы: ``` Введите строку: Привет Введите строку: Это Введите строку: тестовый Введите строку: пример Введите строку: Привет Это тестовый пример ```

Убедитесь, что у вас установлена версия Python 3.8 или выше, так как в примере использован оператор присваивания в условии цикла while, который был введен в Python 3.8. Если у вас другая версия Python, используйте более стандартную форму цикла while, например:

```python line = input("Введите строку: ") while line != '': lines.append(line) line = input("Введите строку: ") ```

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос