Составить программу выполняя которую машина выведет на экран все целые числа от а до б Program
primer war a: inter; begin a: = bОтветы на вопрос
var
a,b,i:integer;
begin
readln(a,b);
for i:=a to b do
write(i,' ');
end.
var a, b, c: integer;
begin
writeln('Введите начало диапазона:');
readln(a);
writeln('Введите конец диапазона:');
readln(b);
while a < b do
begin
inc(a);
Writeln(a);
end;
end.
Для написания программы, которая будет выводить на экран все целые числа от a до b, вам потребуется использовать цикл. В языке программирования Pascal, который я предполагаю, вы можете использовать цикл `for` для достижения этой цели.
Вот пример программы на Pascal:
```pascal program вывод_чисел; var a, b, i: integer; begin // Вводим значения a и b write('Введите значение a: '); readln(a); write('Введите значение b: '); readln(b);
// Определяем диапазон целых чисел от a до b if a <= b then begin // Выводим все целые числа от a до b for i := a to b do writeln(i); end else begin // Выводим все целые числа от b до a for i := a downto b do writeln(i); end; end. ```
В этой программе мы сначала запрашиваем значения a и b у пользователя. Затем, используя условный оператор `if`, мы определяем, какой диапазон чисел нужно вывести - от a до b или от b до a. Затем мы используем цикл `for` для перебора всех целых чисел в заданном диапазоне и выводим их на экран с помощью процедуры `writeln`.
Вы можете скомпилировать и запустить эту программу на любой среде разработки, поддерживающей язык Pascal.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
