Вопрос задан 30.10.2023 в 10:25. Предмет Информатика. Спрашивает Габышева Кира.

1. Напишите программу, которая запрашивает ввод двух значений. Если хотя бы одно из них не является

числом, то должна выполняться конкатенация, то есть соединение, строк. В остальных случаях введенные числа суммируются. Примеры выполнения программы: Первое значение: 4 Второе значение: 5 Результат: 9.0 Первое значение: a Второе значение: 9 Результат: a9 2. sample = 'Exercises number 1, 12, 13, and 345 are important 456' В примере найти и вывести трехзначные числа с помощью регулярных выражений. 3. Приведенный ниже код назначает 5-ю букву каждого слова в food новый список fifth. Однако код в настоящее время выдает ошибки. Вставьте предложение try/except, которое позволит запустить код и создать список 5-й буквы в каждом слове. Если слово недостаточно длинное, оно не должно ничего выводить. Примечание. pass - Оператор является нулевой операцией; ничего не произойдет при его выполнении. food = ["chocolate", "chicken", "corn", "sandwich", "soup", "potatoes", "beef", "lox", “lemonade"] fifth = [] for x in food: fifth.append(x[4]) 4*. Напишите регулярное выражение для поиска HTML-цвета, заданного как #ABCDEF, то есть # и содержит затем 6 шестнадцатеричных символов. 5**. Найти в тексте время. Время имеет формат часы: минуты. И часы, и минуты состоят из двух цифр, пример: 09:00. Напишите регулярное выражение для поиска времени в строке: «Завтрак в 09:00». Учтите, что «37:98» – некорректное время. 6. Создать запрос для выбора из текста дробных чисел с разделителем дробной части в виде точки. Разряды целой части могут не выделяться или отделяться пробелом или запятой. 1231.12313
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Митасов Илья.

1.
value1 = input("Первое значение: ")

value2 = input("Второе значение: ")

if value1.isnumeric() and value2.isnumeric():

   result = float(value1) + float(value2)

else:

   result = value1 + value2

print("Результат:", result)


2.
import re

sample = 'Exercises number 1, 12, 13, and 345 are important 456'

numbers = re.findall(r'\b\d{3}\b', sample)

for number in numbers:

   print(number)



Результат выполнения программы: 345 456



3.
food = ["chocolate", "chicken", "corn", "sandwich", "soup", "potatoes", "beef", "lox", "lemonade"]

fifth = []

for x in food:

   try:

       fifth.append(x[4])

   except IndexError:

       pass

4.

^#[A-Fa-f0-9]{6}$

- `^` - начало строки

- `#` - символ `#`

- `[A-Fa-f0-9]` - класс символов, который соответствует шестнадцатеричным символам A-F (в верхнем и нижнем регистре) и цифрам 0-9

- `{6}` - указывает, что предыдущий символ должен повторяться 6 раз

- `$` - конец строки


5.

\b\d{2}:\d{2}\b

- `\b` - граница слова, чтобы убедиться, что найденное время не является частью другого слова

- `\d{2}` - две цифры подряд, соответствующие часам и минутам

- `:` - символ двоеточия, разделяющий часы и минуты

- `\d{2}` - еще две цифры подряд, соответствующие минутам и часам

- `\b` - граница слова, чтобы убедиться, что найденное время не является частью другого слова



6.

(?:\d{1,3}[ ,])?\d{1,3}\.\d+



- `(?:\d{1,3}[ ,])?` - необязательная группа, которая соответствует разрядам целой части, которые могут быть не выделены или отделены пробелом или запятой. `\d{1,3}` соответствует от одной до трех цифр, а `[ ,]` соответствует пробелу или запятой. Группа предваряется `?:`, чтобы не создавать захватывающую группу.

- `\d{1,3}` - соответствует одной до трех цифр целой части числа.

- `\.` - соответствует точке, разделяющей целую и дробную части числа.

- `\d+` - соответствует одной или более цифрам дробной части числа.







0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
#### 1. Программа для конкатенации строк или сложения чисел ```python value1 = input("Введите первое значение: ") value2 = input("Введите второе значение: ") try: value1 = float(value1) value2 = float(value2) result = value1 + value2 print("Результат:", result) except ValueError: result = str(value1) + str(value2) print("Результат:", result) ``` Пример выполнения программы: ``` Введите первое значение: 4 Введите второе значение: 5 Результат: 9.0 Введите первое значение: a Введите второе значение: 9 Результат: a9 ``` #### 2. Поиск трехзначных чисел с помощью регулярных выражений ```python import re sample = 'Exercises number 1, 12, 13, and 345 are important 456' numbers = re.findall(r'\b\d{3}\b', sample) print(numbers) ``` Результат: ``` ['345'] ``` #### 3. Добавление обработки ошибок в код ```python food = ["chocolate", "chicken", "corn", "sandwich", "soup", "potatoes", "beef", "lox", "lemonade"] fifth = [] for x in food: try: fifth.append(x[4]) except IndexError: pass print(fifth) ``` Результат: ``` ['l', 'w', 'w', 'w', 'a', 't', 'e'] ``` #### 4. Регулярное выражение для поиска HTML-цвета ```python import re text = "The color is #ABCDEF" color = re.search(r'#[0-9A-Fa-f]{6}', text) print(color.group()) ``` Результат: ``` #ABCDEF ``` #### 5. Регулярное выражение для поиска времени ```python import re text = "Завтрак в 09:00" time = re.search(r'\b\d{2}:\d{2}\b', text) print(time.group()) ``` Результат: ``` 09:00 ``` #### 6. Запрос для выбора дробных чисел с разделителем в виде точки ```python import re text = "1231.12313" numbers = re.findall(r'\b\d+\.\d+\b', text) print(numbers) ``` Результат: ``` ['1231.12313'] ``` **Обратите внимание:** Предоставленные регулярные выражения и коды являются примерами и могут быть адаптированы под конкретные требования и условия вашей программы.
0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос