Вопрос задан 28.10.2023 в 08:51.
Предмет Информатика.
Спрашивает Костиков Дмитрий.
ДАЮ 40 БАЛЛОВ! СРОЧНО! Составьте программу, которая вычисляет периметр треугольника со сторонами
a,b,c и выводит результат на экран.Ответы на вопрос
Отвечает Кабанов Андрей.
Ответ:
если на паскале, то вот
блин это для площади
program perimetr;
var P, a, b, c:Integer;
begin
writeln('ввести данные') ;
write (a, b, c) ;
readln (a, b, c);
P:=a+b+c;
writeln ('P= ', P) ;
end.
Объяснение:
program treygolnik;
uses crt;
var a, b, c, h, s:real;
begin
writeln ('введите переменные:');
write ('b = '); readln (b);
write ('h = '); readln (h);
s:= (b*h)/2;
writeln ('Ответ:');
writeln ('S = ', s);
end.
Отвечает Ващенко Анастасия.
Ответ:
var a,b,c,P:integer;
begin
readln(a,b,c);
P:=a+b+c;
writeln(P);
end.
Объяснение:
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Python, которая вычисляет периметр треугольника:
```python
# Вводим значения сторон треугольника
a = float(input("Введите длину стороны a: "))
b = float(input("Введите длину стороны b: "))
c = float(input("Введите длину стороны c: "))
# Вычисляем периметр треугольника
perimeter = a + b + c
# Выводим результат на экран
print("Периметр треугольника равен:", perimeter)
```
Программа сначала запрашивает у пользователя длины сторон треугольника `a`, `b` и `c` с помощью функции `input`. Затем производится вычисление периметра, путем сложения длин всех трех сторон. И наконец, результат выводится на экран с помощью функции `print`.
Надеюсь, это поможет вам!
0
0
```python
# Вводим значения сторон треугольника
a = float(input("Введите длину стороны a: "))
b = float(input("Введите длину стороны b: "))
c = float(input("Введите длину стороны c: "))
# Вычисляем периметр треугольника
perimeter = a + b + c
# Выводим результат на экран
print("Периметр треугольника равен:", perimeter)
```
Программа сначала запрашивает у пользователя длины сторон треугольника `a`, `b` и `c` с помощью функции `input`. Затем производится вычисление периметра, путем сложения длин всех трех сторон. И наконец, результат выводится на экран с помощью функции `print`.
Надеюсь, это поможет вам!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 37
Информатика 55
Информатика 12
Информатика 266
Информатика 25
Информатика 33
Информатика 16
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
