Задача по Pascal ABC. Даю 90 баллов!!! Используйте if, for, writeln, write, read, readln, var,
begin, end, int64 и добавьте несколько переменных например: i,max. Нужно на завтра к 9!!!! Дана последовательность из 20 целых чисел. Определите количество чисел в наиболее длинной подпоследовательности из подряд идущих нулей. Формат входных данных В программу вводятся 20 целых чисел, принадлежащих диапазону [−215;215−1], по 10 чисел на строке. Формат выходных данных Программа должна вывести количество нулей в наиболее длинной подпоследовательности. Примеры входные данные 1 1 1 1 0 0 0 0 0 0 1 1 1 1 0 1 0 1 0 1 выходные данные 6Ответы на вопрос
const n=20;
var a:array[1..n] of int64;
max, k, i, j: integer;
begin
for j:=0 to 1 do
begin
for i:=1 to n div 2 do read(a[j*10+i]);
readln;
end;
max:=0;
k:=0;
for i:=1 to n do
if a[i]=0 then k:=k+1
else begin
if k>max then max:=k;
k:=0;
end;
if k>max then max:=k;
writeln(max);
end.
Пример:
1 1 1 1 0 0 0 0 0 0
1 1 1 1 0 1 0 1 0 1
6
Я могу помочь вам с вашей задачей по Pascal ABC. Вот возможный код, который решает вашу задачу:
```pascal var i, n, max, cur: int64; // объявляем переменные begin max := 0; // инициализируем максимальную длину нулевой подпоследовательности cur := 0; // инициализируем текущую длину нулевой подпоследовательности for i := 1 to 20 do // цикл по 20 числам begin read(n); // считываем очередное число if n = 0 then // если число равно нулю begin cur := cur + 1; // увеличиваем текущую длину на единицу if cur > max then // если текущая длина больше максимальной max := cur; // обновляем максимальную длину end else // если число не равно нулю cur := 0; // обнуляем текущую длину end; writeln(max); // выводим максимальную длину на экран end. ```
Надеюсь, это поможет вам с вашей задачей. Удачи!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
