Вопрос задан 27.10.2023 в 08:41. Предмет Информатика. Спрашивает Ситников Миша.

напишите программу на формальном языке Паскаль , которая будет находить сумму 10 элементов массива

, числа в котором выбраны случайным образом в пределах 50.
0 1
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Strebanyov Daniil.
var a:array [1..10] of integer;
i,s:integer;
begin
for i:=1 to 10 do begin
a[i]:=random(50);
s:=s+a[i];
write(a[i],' ');
end;
writeln;
writeln ('summa=',s);
readln;
end.
1 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Pascal, который генерирует массив из 10 случайных чисел в пределах от 1 до 50 и затем находит их сумму:

```pascal program SumOfArrayElements;

const ARRAY_SIZE = 10; MAX_VALUE = 50;

var arr: array[1..ARRAY_SIZE] of Integer; i, sum: Integer;

// Функция для генерации случайных чисел в пределах от 1 до MAX_VALUE function RandomNumber: Integer; begin RandomNumber := Random(MAX_VALUE) + 1; end;

begin Randomize; // Инициализация генератора случайных чисел

// Заполнение массива случайными числами for i := 1 to ARRAY_SIZE do arr[i] := RandomNumber;

// Вывод сгенерированного массива writeln('Сгенерированный массив:'); for i := 1 to ARRAY_SIZE do write(arr[i], ' ');

// Нахождение суммы элементов массива sum := 0; for i := 1 to ARRAY_SIZE do sum := sum + arr[i];

writeln; writeln('Сумма элементов массива:', sum); end. ```

Эта программа начинается с определения констант `ARRAY_SIZE`, устанавливающей размер массива (в данном случае 10), и `MAX_VALUE`, который устанавливает верхнюю границу для случайных чисел (в данном случае 50).

Затем программа использует генератор случайных чисел `Randomize` для инициализации и заполняет массив `arr` из 10 элементов случайными числами в диапазоне от 1 до 50. После этого она выводит массив на экран.

Далее, программа вычисляет сумму всех элементов в массиве и выводит полученную сумму на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос