Написать программу в C# Выведите на экран n раз фразу "Silence is golden". Число n вводит
пользователь.Ответы на вопрос
public class Program{ public static void Main() { string i = Console.ReadLine(); int b = Convert.ToInt32(i); for (int a = 0; a < b; a ++) Console.WriteLine("Silence is golden"); }}
Я попробую помочь вам с написанием программы на C#. Вот один из возможных вариантов решения вашей задачи:
```csharp using System;
class Program { static void Main() { // Вводим число n с клавиатуры Console.Write("Введите число n: "); int n = int.Parse(Console.ReadLine());
// Выводим фразу "Silence is golden" n раз for (int i = 0; i < n; i++) { Console.WriteLine("Silence is golden"); } } } ```
Эта программа использует класс `Console` из пространства имен `System` для ввода и вывода данных. Метод `Console.Write` печатает строку без перевода каретки, а метод `Console.ReadLine` считывает строку с клавиатуры. Метод `int.Parse` преобразует строку в целое число. Для повторения фразы "Silence is golden" n раз используется цикл `for`, в котором переменная `i` меняется от 0 до n-1. Метод `Console.WriteLine` печатает строку с переводом каретки.
Надеюсь, это было полезно.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
