Вопрос задан 23.10.2023 в 06:37.
Предмет Информатика.
Спрашивает Гречко Даниил.
Написать программу в паскале напечатать все положительные нечётные трёхзначные числа
Ответы на вопрос
Отвечает Ким Нурик.
Program rd;
var i:integer;
begin
for i:=100 to 999 do if i mod 2 = 1 then write(i,' ');
end.
var i:integer;
begin
for i:=100 to 999 do if i mod 2 = 1 then write(i,' ');
end.
Отвечает Амиров Парвиз.
PascalABC.NET 3.2
begin Range(101,999,2).Println end.
begin Range(101,999,2).Println end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на Pascal, которая печатает все положительные нечётные трёхзначные числа:
pascalprogram PrintOddNumbers; var i: integer; begin for i := 101 to 999 step 2 do begin writeln(i); end; end.
Эта программа использует цикл for, который начинается с 101 (первое трёхзначное нечётное число) и увеличивается на 2 на каждой итерации, чтобы получить следующее нечётное число. Когда i превышает 999, программа завершается.
Она выводит все нечётные трёхзначные числа от 101 до 999 включительно.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
