Вопрос задан 24.07.2018 в 22:40. Предмет Информатика. Спрашивает Иванова Анастасия.

Задачи нужно решить на языке Паскаль. Изучаем string. 1.Вовочка скучая на уроке придумал себе игру.

Он открывал книгу на любой странице. Выделял фрагмент текста, загадывал символ и подсчитывал сколько раз эта буква встречалась в фрагменте. Составить программу, которая подсчитывает, сколько раз загаданная буква встречается в строке. 2.Вася Пупкин очень плохо писал диктанты. Чаще всего Вася писал двойные буквы. Ваше задача написать программу которая удалит из текста повторяющиеся символы.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Огнева Даша.
//PascalABC.NET 3.2 сборка 1318

//1

Var 
 s:string;
  c:char;
  counter:integer;
begin
readln(s);
readln(c);
while pos(c,s)<>0 do
  begin
    inc(counter);
    delete(s,pos(c,s),1);
  end;
writeln(counter);
end.

Пример ввода:
banana
a
Пример вывода:
3

//2

Var
  s:string;
  i:integer;
begin
readln(s);
i:=2;
while i<=length(s) do
if s[i-1]=s[i] then
 delete(s,i,1)
 else
 inc(i);
writeln(s);
end.

Пример ввода:
saad
Пример вывода:
sad
0 0
Отвечает Баженова Анна.
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Текст:');
  var c:=ReadlnChar('Буква:');
  Writeln('Буква встречается ',s.Where(p->p=c).Count,' раз(а)')
end.

Пример
Текст: а роза упала на лапу азора
Буква: а
Буква встречается 8 раз(а)

// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Текст:');
  var m:=s.MatchValues('(\w)\1{1}').Distinct;
  foreach var cc in m do s:=s.Replace(cc,cc[1]);
  s.Println
end.

Пример
Текст: стеклянный оловянный длинношеее искусство
стекляный оловяный длиношее искуство



0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Решение задач на языке Паскаль

Для решения задач на языке Паскаль, вам потребуется написать соответствующий код. Давайте начнем с первой задачи.

Задача 1: Подсчет количества раз, которое встречается буква в строке

Для решения этой задачи вам понадобится написать программу, которая будет считать, сколько раз заданная буква встречается во введенной строке.

Пример кода на языке Паскаль: ```pascal program CountLetterOccurrences; var text, letter: string; count, i: integer; begin count := 0; writeln('Введите текст:'); readln(text); writeln('Введите букву для подсчета:'); readln(letter); for i := 1 to length(text) do begin if text[i] = letter then count := count + 1; end; writeln('Буква ', letter, ' встречается ', count, ' раз(а) в тексте.'); end. ``` Этот код позволит пользователю ввести текст и букву, после чего программа подсчитает, сколько раз данная буква встречается в тексте.

Задача 2: Удаление повторяющихся символов из текста

Для решения этой задачи вам потребуется написать программу, которая будет удалять повторяющиеся символы из введенной строки.

Пример кода на языке Паскаль: ```pascal program RemoveDuplicateCharacters; var text, result: string; i: integer; begin result := ''; writeln('Введите текст:'); readln(text); for i := 1 to length(text) do begin if pos(text[i], result) = 0 then result := result + text[i]; end; writeln('Текст без повторяющихся символов: ', result); end. ``` Этот код позволит пользователю ввести текст, после чего программа удалит повторяющиеся символы и выведет результат.

Надеюсь, эти примеры помогут вам решить задачи на языке Паскаль. Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос