Free Pascal. Нужно написать программу, где после каждой буквы Ch вставляется строка Str1.
Ответы на вопрос
        program Project4;
var ch:char; str,str1,str2:string; i:integer;
begin
writeln('Введите исходный текст:');
readln(str);
writeln('Введите строку которую нужно вставить:');
readln(str1);
writeln('Введите символ после которого нужно вставить:');
readln(ch);
str2:='';
i:=pos(ch,str);
while i>0 do begin
str2:=str2+copy(str,1,i)+str1;
delete(str,1,i);
i:=pos(ch,str);
end;
writeln('Результирующая строка: ',str2);
readln;
end.
        s,str1:string;
ch:char;
i:integer;
begin
Write('Введите текст: '); ReadLn(s);
Write('Введите искомый символ: '); Readln(ch);
Write('Введите добавляемый текст: '); Readln(str1);
for i:=Length(s) downto 1 do
if s[i]=ch then Insert(str1,s,i+1);
Writeln('Результат: ',s);
Readln;
end.
Тестовое решение:
Введите текст: А роза упала на лапу Азора
Введите искомый символ: а
Введите добавляемый текст: 12345
Результат: А роза12345 упа12345ла12345 на12345 ла12345пу Азора12345
            Для написания программы на Free Pascal, где после каждой буквы "Ch" вставляется строка "Str1", вы можете использовать следующий код:
```pascal program InsertString;
var InputString, OutputString, Str1: string; i: integer;
begin Str1 := 'Str1'; // Ввод строки writeln('Введите строку:'); readln(InputString); // Вставка строки после каждой буквы "Ch" OutputString := ''; for i := 1 to length(InputString) do begin OutputString := OutputString + InputString[i]; if (InputString[i] = 'C') and (i < length(InputString)) and (InputString[i+1] = 'h') then OutputString := OutputString + Str1; end; // Вывод результата writeln('Результат:'); writeln(OutputString); end. ```
В этом коде мы сначала объявляем переменные `InputString`, `OutputString` и `Str1`. Затем мы запрашиваем у пользователя ввод строки и сохраняем ее в `InputString`. Далее мы проходим по каждому символу в `InputString` и добавляем его в `OutputString`. Если текущий символ - "C", а следующий символ - "h", мы также добавляем `Str1` в `OutputString`. В конце мы выводим результат.
Примечание: Пожалуйста, учтите, что код может быть доработан в зависимости от ваших конкретных требований.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			