Написать программу на паскале по этому описанию даны две последовательности: С1, С2, ..., С7; Р1,
Р2, ..., Р7. Если каждый элемент первой последоваткльности меньше суммы элементов второй, найти при каких згачениях i, j максимально значениевыражения Сi/(Pj+Ci^2) ПОЖАЛУЙСТА, КТО МОЖЕТ ПОМОГИТЕ! БУДУ ОЧЕНЬ БЛАГОДАРЕН ! ЖЕЛАТЕЛЬНО КАК МОЖНО БЫСТРЕЕОтветы на вопрос
// PascalABC.NET 3.4.2, сборка 1797 от 22.09.2018
// Внимание! Если программа не работает, обновите версию!
begin
var c := ArrRandom(7, -5, 5);
c.Println;
var p := ArrRandom(7, -50, 50);
p.Println;
var s2 := p.Sum;
if c.All(t -> t < s2) then
begin
var k := c.Cartesian(p, (i, j)-> (i, j, i / (j + i * i))).MaxBy(t -> t[2]);
var i := c.IndexOf(k[0]) + 1;
var j := p.IndexOf(k[1]) + 1;
Println($'Максимум {k[2]:g6} при i={i}, j={j}')
end
end.

Если нужен ввод с клавиатуры, то вместо var C := ArrRandom... напишите var C := ReadArrInteger(n) или ReadArrReal(n)


Конечно, вот программа на языке Pascal, которая выполняет указанные вами действия:
pascalprogram MaxExpression; var C, P: array[1..7] of Real; i, j: Integer; maxVal, currentVal: Real; begin { Ввод элементов последовательности C } writeln('Введите элементы последовательности C:'); for i := 1 to 7 do readln(C[i]); { Ввод элементов последовательности P } writeln('Введите элементы последовательности P:'); for i := 1 to 7 do readln(P[i]); maxVal := -1; { Начальное значение максимального значения выражения } for i := 1 to 7 do for j := 1 to 7 do begin { Проверка условия: каждый элемент C должен быть меньше суммы элементов P } if C[i] < (P[j] + C[i] * C[i]) then begin { Вычисление значения выражения } currentVal := C[i] / (P[j] + C[i] * C[i]); { Если текущее значение больше максимального, обновляем максимальное значение } if currentVal > maxVal then begin maxVal := currentVal; writeln('Максимальное значение: ', maxVal:0:2, ' при i = ', i, ' и j = ', j); end; end; end; readln; end.
Вы можете скопировать этот код в среду разработки Pascal и выполнить его, чтобы найти значения i и j, при которых выражение Ci / (Pj + Ci^2) максимально. В программе предполагается, что последовательности C и P состоят из 7 элементов каждая.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
