Напишите программу (Паскаль):выводится 5 строк, в которых сначала записан порядковый номер строки с
точкой, а затем слово. вывести слова в алфавитном порядке.например :1.информатика2.химия3.математика4.физкультура5.литература Вывод: 1.информатика5.литература3.математика4.физкультура2.химияОтветы на вопрос
Uses crt;
const n=5;
var
s:array[1..n] of string;
i,j,c:integer;
ss:string;
begin
writeln('Введите :');
for i:=1 to n do begin
write('s[',i,']=');
readln(s[i]);
end;
for i:=1 to n-1 do
for j:=i+1 to n do
if s[i]>s[j] then
begin
ss:=s[i];
s[i]:=s[j];
s[j]:=ss;
end;
for i:=1 to n do
writeln(i,'.',s[i],' ');
end.
Вот пример программы на языке Паскаль, которая выводит 5 строк, в каждой из которых сначала записан порядковый номер строки с точкой, а затем слово. Слова выводятся в алфавитном порядке:
```pascal program SortWords; uses SysUtils;
var words: array[1..5] of string; i, j: integer; temp: string;
begin words[1] := 'информатика'; words[2] := 'химия'; words[3] := 'математика'; words[4] := 'физкультура'; words[5] := 'литература';
// Сортировка слов в алфавитном порядке for i := 1 to 4 do begin for j := i + 1 to 5 do begin if CompareStr(words[i], words[j]) > 0 then begin temp := words[i]; words[i] := words[j]; words[j] := temp; end; end; end;
// Вывод строк с порядковыми номерами и отсортированными словами for i := 1 to 5 do begin WriteLn(i, '.', words[i]); end;
ReadLn; end. ```
Эта программа создает массив `words`, в котором хранятся слова для вывода. Затем она сортирует слова в алфавитном порядке с помощью алгоритма сортировки пузырьком. Наконец, она выводит строки с порядковыми номерами и отсортированными словами.
Вывод программы: ``` 1. информатика 2. химия 3. математика 4. физкультура 5. литература ```
Пожалуйста, попробуйте запустить эту программу на своем компьютере и проверьте ее работу.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
