Вопрос задан 06.10.2023 в 03:44. Предмет Информатика. Спрашивает Осипов Слава.

Язык программирования Python. Работа со строками, списками и словарями1. Есть список a = [1, 1,

2, 3, 5, 8, 13, 21, 34, 55, 89]. Выведите всеэлементы, которые меньше 5.2. Даны списки:a = [1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89];b = [1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13].Нужно вернуть список, который состоит из элементов, общих для этихдвух списков.3. Напишите программу для слияния нескольких словарей в один.dict_a = {1:10, 2:20}dict_b = {3:30, 4:40}dict_c = {5:50, 6:60}4. Вы принимаете от пользователя последовательность чисел,разделённых запятой. Составьте список и кортеж с этими числами.5. Выведите первый и последний элемент списка.6. Напишите программу, которая принимает в качестве аргумента имяфайла и выводит его расширение. Если расширение у файла определитьневозможно, верните строку «Unknown file type».7. При заданном целом числе n посчитайте n + nn + nnn.8. Напишите программу, которая принимает два списка и выводит всеэлементы первого, которых нет во втором.9. Сложите цифры целого числа.10. Посчитайте, сколько раз символ встречается в строке.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Леонардыч Евгений.

____________________________ #1

a = [1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89].

for i in a:

   if a < 5:

       print(a)

____________________________ #2

def f(a, b):  #функция для сливания двух списков

   ab = a + b

   ab.sort()

   return list(dict.fromkeys(ab))

____________________________ #3

dict_a = {1:10, 2:20}

dict_b = {3:30, 4:40}

dict_c = {5:50, 6:60}

def update(a, b, c):

   a.update(b)

   a.update(c)

update(dict_a, dict_b, dict_c)

____________________________ #4

array = list(map(int, input().split(",")))

cortex = tuple(array)

____________________________ #5

array = [] #здесь твой данный список

print(array[0], array[len(array) - 1])

____________________________ #6

def f(filename):

   try:

       return filename[filename.index(".") + 1:]

   except:

       return "Unknown file type"

____________________________ #7

n = int(input())

print(n + n ** 2 + n ** 3)

____________________________ #8

x = list(input())

f = list(input())

print(sorted(set(f) - set(x)))

____________________________ #9

num = int(input())

print(sum(list(map(int, str(num)))))

____________________________ #10

string = str(input())

print(string.count('a'))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Давайте по порядку рассмотрим каждую из ваших задач:

  1. Выведите все элементы списка a, которые меньше 5.
python
a = [1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89] result = [x for x in a if x < 5] print(result)
  1. Вернуть список, который состоит из элементов, общих для списков a и b.
python
a = [1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89] b = [1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13] result = list(set(a) & set(b)) print(result)
  1. Программа для слияния нескольких словарей в один:
python
dict_a = {1: 10, 2: 20} dict_b = {3: 30, 4: 40} dict_c = {5: 50, 6: 60} merged_dict = {} merged_dict.update(dict_a) merged_dict.update(dict_b) merged_dict.update(dict_c) print(merged_dict)
  1. Создание списка и кортежа из последовательности чисел, введенной пользователем:
python
input_string = input("Введите последовательность чисел, разделенных запятой: ") numbers_list = [int(x) for x in input_string.split(",")] numbers_tuple = tuple(numbers_list) print("Список:", numbers_list) print("Кортеж:", numbers_tuple)
  1. Вывод первого и последнего элемента списка:
python
first_element = numbers_list[0] last_element = numbers_list[-1] print("Первый элемент:", first_element) print("Последний элемент:", last_element)
  1. Программа для вывода расширения файла по имени файла:
python
file_name = input("Введите имя файла: ") file_parts = file_name.split(".") if len(file_parts) > 1: extension = file_parts[-1] print("Расширение файла:", extension) else: print("Unknown file type")
  1. Вычисление n + nn + nnn:
python
n = int(input("Введите целое число n: ")) result = n + int(str(n) + str(n)) + int(str(n) + str(n) + str(n)) print("Результат:", result)
  1. Вывод всех элементов первого списка, которых нет во втором списке:
python
list1 = [1, 2, 3, 4, 5] list2 = [3, 4, 5, 6, 7] result = [x for x in list1 if x not in list2] print(result)
  1. Сложение цифр целого числа:
python
number = int(input("Введите целое число: ")) digit_sum = sum(int(digit) for digit in str(number)) print("Сумма цифр числа:", digit_sum)
  1. Подсчет количества вхождений символа в строку:
python
input_string = input("Введите строку: ") character = input("Введите символ для подсчета: ") count = input_string.count(character) print(f"Символ '{character}' встречается {count} раз(а) в строке.")

Надеюсь, эти примеры помогут вам работать с разными аспектами Python.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос