
Необходимо было написать программу, которая позволяет найти наименьшее число, большее 500,
кратное 17 и вывести его на экран.Программист торопился и написал программу с ошибками. Укажите строки,в которых допущены ошибки.Var x: integer; Begin x:= 500; Repeat ox := х – 1; Until x mod 17 <> 0Writeln (х);End.

Ответы на вопрос

Var x: integer;
Begin
x:= 500;
Repeat o //здесь непонятный символ o (должно быть: Repeat)
x := х – 1; //здесь должно быть наоборот: к x надо прибавлять 1, так как надо найти число большее 500 (должно быть: x:= x + 1;)
Until x mod 17 <> 0 //здесь ошибка в том, что цикл repeat остановится когда число, деленное на 17, будет иметь остаток, а надо остановить тогда, когда при делении числа на 17 будет 0, то есть делится на 17 без остатка(должно быть: Until x mod 17 = 0;)
Writeln (х);
End.



Здесь есть несколько опечаток и ошибок в коде. Вот исправленный вариант:
pascalVar x: integer; Begin x := 500; Repeat x := x + 1; // Исправлена опечатка, должно быть x := x + 1; Until x mod 17 = 0; // Исправлено условие, должно быть x mod 17 = 0; Writeln(x); End.
Исправления включают в себя изменение оператора :=
в строке x := x + 1;
и замену условия в строке Until x mod 17 = 0;
. Теперь программа должна правильно находить наименьшее число, большее 500, кратное 17.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili