Вопрос задан 05.10.2023 в 13:55. Предмет Информатика. Спрашивает Рябов Сергей.

Напишите программу на python, которая вычисляет средний рост учеников. Алгоритм должен в цикле

просить пользователя ввести рост ученика. Цикл завершается, когда пользователь введет рост, равный нулю. Программа должна вывести средний рост учеников в классе. Формат ввода Вводятся целые числа одно за другим, на отдельных строках. Формат вывода Выводтся одно значение среднего роста
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Мамченко Анастасия.

n=0

s=0

a=1

while a!=0:

   a=int(input())

   n+=1

   s+=a

print(s/(n-1))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот программа на Python, которая вычисляет средний рост учеников, принимая ввод от пользователя до тех пор, пока пользователь не введет рост, равный нулю:

python
# Инициализируем переменные для хранения суммы роста и количества учеников total_height = 0 num_students = 0 # Вход в бесконечный цикл while True: # Просим пользователя ввести рост ученика и преобразуем его в целое число height = input("Введите рост ученика (0 для завершения): ") height = int(height) # Проверяем, равен ли введенный рост нулю if height == 0: break # Выходим из цикла, если рост равен нулю # Добавляем рост к общей сумме и увеличиваем счетчик учеников total_height += height num_students += 1 # Проверяем, чтобы не делить на ноль (если не было введено ни одного роста) if num_students > 0: # Вычисляем средний рост и выводим результат average_height = total_height / num_students print(f"Средний рост учеников: {average_height:.2f}") else: print("Нет данных для вычисления среднего роста.")

Эта программа будет запрашивать рост учеников до тех пор, пока пользователь не введет 0. После ввода 0 программа вычислит и выведет средний рост учеников в классе.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос