Написать программу в Паскале. (задача) Пользователь вводит целые числа, 0 это финиш,
просуммировать все числа в диапазоне от 5 до 15 включительноОтветы на вопрос
//PascalABC.NET
//Версия 3.3, сборка 1634
begin
write(ReadSeqIntegerWhile(x->x<>0).Where(f->f in [5..15]).Sum);
end.
Я могу помочь вам с написанием программы на Паскале. Ваша задача состоит в том, чтобы просуммировать все целые числа, введенные пользователем, которые находятся в диапазоне от 5 до 15 включительно. Для этого вам нужно использовать цикл и условный оператор. Вот пример кода, который решает вашу задачу:
``` program SumInRange; var x, sum: integer; begin sum := 0; // инициализируем сумму нулем repeat readln(x); // читаем число из ввода if (x >= 5) and (x <= 15) then // проверяем, что число в диапазоне sum := sum + x; // добавляем число к сумме until x = 0; // повторяем, пока не введен ноль writeln('Сумма чисел в диапазоне от 5 до 15 равна ', sum); // выводим результат end. ```
Вы можете узнать больше о программировании на Паскале из этих источников: [Pascal Programming/Input and Output - Wikibooks](https://en.wikibooks.org/wiki/Pascal_Programming/Input_and_Output), [Pascal Tutorial - Online Courses and eBooks Library](https://www.tutorialspoint.com/pascal/index.htm), [Pascal - Program Structures - Online Tutorials Library](https://www.tutorialspoint.com/pascal/pascal_program_structure.htm), [Basic PASCAL Programming - Seton Hall University](http://pirate.shu.edu/~wachsmut/Teaching/CSAS1111/Notes-Pascal/pascal1.html). Надеюсь, это было полезно. Спасибо за обращение к Bing.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
