Язык программирования: C или C++. Написать программу. Заполнить массив из 10 элементов случайными
числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую – по убыванию.Ответы на вопрос
#include <iostream>
#include <vector>
#include <cstdlib>
#include <ctime>
#include <algorithm>
using namespace std;
int main() {
vector<int> arr;
srand(time(0));
for (int i = 0; i < 10; ++i) {
arr.push_back(rand() % 101);
cout << arr[i] << " ";
}
cout << endl << "Sorted: ";
for (int j = 0; j < 100; ++j) {
for (int i = 0; i < arr.size()-1; ++i) {
if (i < 4) {
if (arr[i] > arr[i + 1]) {
swap(arr[i], arr[i + 1]);
}
}
else {
if (arr[i] < arr[i + 1]) {
swap(arr[i], arr[i + 1]);
}
}
}
}
for (int i = 0; i < 10; ++i) {
if (i == 5) {
cout << "/// ";
}
cout << arr[i] << " ";
}
}
Конечно, вот пример программы на языке C++, которая выполняет указанные действия:
cpp#include <iostream>
#include <cstdlib>
#include <ctime>
#include <algorithm>
int main() {
const int arraySize = 10;
int arr[arraySize];
// Инициализация генератора случайных чисел
std::srand(std::time(nullptr));
// Заполняем массив случайными числами в интервале [0..100]
for (int i = 0; i < arraySize; ++i) {
arr[i] = std::rand() % 101;
}
// Вывод неотсортированного массива
std::cout << "Неотсортированный массив: ";
for (int i = 0; i < arraySize; ++i) {
std::cout << arr[i] << " ";
}
std::cout << std::endl;
// Сортируем первую половину по возрастанию
std::sort(arr, arr + arraySize / 2);
// Сортируем вторую половину по убыванию
std::sort(arr + arraySize / 2, arr + arraySize, std::greater<int>());
// Вывод отсортированного массива
std::cout << "Отсортированный массив: ";
for (int i = 0; i < arraySize; ++i) {
std::cout << arr[i] << " ";
}
std::cout << std::endl;
return 0;
}
Эта программа создает массив из 10 случайных чисел в интервале [0..100], сортирует первую половину по возрастанию, а вторую половину по убыванию, и выводит исходный и отсортированный массивы.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
