C++Напишите программу с функцией, которая из двух чисел возвращает минимальное число
Ответы на вопрос
Ответ:
#include <iostream>
#include <set>
#include <stack>
#include <vector>
#include <algorithm>
#include <string>
#include <iomanip>
#include <cmath>
using namespace std;
#define ll long long
#define ld long double
#define vi vector<int>
#define elif else if
#define ull unsigned long long
#define ui unsigned int
#define zelenskiy ios::sync_with_stdio(false); cin.tie(0); cout.tie(0);
#define fori for (int i = 0; i < n; ++i)
#define forj for (int j = 0; j < n; ++j)
#define wt while(true)
int min1(int a, int b){
if (a < b) return a;
else return b;
}
using namespace std;
int main() {
int a,b;
cin >> a >> b;
cout << min1(a,b);
}
Объяснение:
Все просто
Конечно, вот пример программы на C++, которая принимает два числа и возвращает минимальное из них:
cpp#include <iostream>
// Функция для нахождения минимального числа
int findMinimum(int num1, int num2) {
if (num1 < num2) {
return num1;
} else {
return num2;
}
}
int main() {
int number1, number2;
std::cout << "Введите первое число: ";
std::cin >> number1;
std::cout << "Введите второе число: ";
std::cin >> number2;
int minNumber = findMinimum(number1, number2);
std::cout << "Минимальное число: " << minNumber << std::endl;
return 0;
}
Эта программа объявляет функцию findMinimum, которая принимает два целых числа и возвращает минимальное из них. В функции main пользователь вводит два числа, затем программа вызывает findMinimum и выводит результат.
Вы можете скомпилировать и запустить эту программу на своем компьютере, чтобы убедиться, что она работает правильно.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
