Вопрос задан 29.09.2023 в 13:27. Предмет Информатика. Спрашивает Бобылёва Даша.

Срочно, 60 баллов!!! 8 класс Написать программу в PascalABC.net 3.7.1.: 1.Среди К чисел, которые

мы будем вводить с клавиатуры из диапазоне от 50 до 100 найти сумму чисел, которые кратные 2 и 3 и количество чисел, которые НЕ кратны 2 и 3. 2.Напишите программу, которая вводит N произвольных чисел и находит количество и сумму четных чисел.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Павленко Андрей.

Задание 1)

var

  k,i,s,s2 : integer;

begin

  s:=0; s2:=0;

  for i:=50 to 100 do

     begin

 write('k - ', i, ' = '); read(k);

 if (k mod 2 = 0) or (k mod 3 = 0) then

    s:=s+k;

 if (k mod 2 <> 0) or (k mod 3 <> 0) then

    s2:=s2+k;

     end;

  writeln('Сумма кратных 2 и 3 = ', s);

  writeln('Сумма не кратных 2 и 3 = ', s2);

end.

Объяснение:

Инициализируем переменные, запускаем цикл от 50 до 100, считываем значение k и проверяем кратно ли оно 2 и 3, или нет. Если да - складываем с переменной s. Если нет - с переменной s2. Выводим суммы чисел.

Задание 2)

var

  n,s,r,x,i : integer;

begin

  r:=0;

  s:=0;

  write('n = '); read(n);

  for i:=1 to n do

     begin

 readln(x);

 if x mod 2 = 0 then

    begin

       s:=s+x;

       r:=r+1;

    end;

     end;

  writeln('Сумма четных чисел: ', s);

  writeln('Колличество четных чисел: ', r);

end.

Объяснение:

Инициализируем переменные, считываем N, запускаем цикл от 1 до n.

Считываем в цикле значение x и проверяем четное ли оно. Если да - складываем его сумму и считаем сколько их (Переменные s и r). Затем выводим их.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для выполнения задачи 1 и 2 в PascalABC.net 3.7.1 можно использовать следующий код:

pascal
program SumAndCount; var K, N, Num, SumEven, CountNotDivisible: integer; begin SumEven := 0; CountNotDivisible := 0; // Задача 1: Находим сумму чисел, кратных 2 и 3, // и количество чисел, НЕ кратных 2 и 3 writeln('Введите количество чисел (N): '); readln(N); for K := 1 to N do begin writeln('Введите число: '); readln(Num); if (Num >= 50) and (Num <= 100) then begin if (Num mod 2 = 0) and (Num mod 3 = 0) then SumEven := SumEven + Num else if (Num mod 2 <> 0) and (Num mod 3 <> 0) then CountNotDivisible := CountNotDivisible + 1; end; end; writeln('Сумма чисел, кратных 2 и 3: ', SumEven); writeln('Количество чисел, НЕ кратных 2 и 3: ', CountNotDivisible); // Задача 2: Находим количество и сумму четных чисел SumEven := 0; writeln('Введите количество чисел (N): '); readln(N); for K := 1 to N do begin writeln('Введите число: '); readln(Num); if Num mod 2 = 0 then SumEven := SumEven + Num; end; writeln('Сумма четных чисел: ', SumEven); writeln('Количество четных чисел: ', N); end.

Программа начинает считывать числа и выполняет обе задачи. Задача 1 решается сначала, а затем программа переходит ко второй задаче.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос