Вопрос задан 29.09.2023 в 02:20. Предмет Информатика. Спрашивает Якушева Ксения.

На языке джава. Написать программу, в результате которой считается сумма элементов целочисленного

массива с помощью циклов for, while, do while, результат выводится на экран.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Раписбай Ильяс.

//С циклом for:

import java.util.Scanner;

import java.util.Arrays; //Если захочется напечатать в консоль массив

public class MyClass {

   public static void main(String args[]) {

       Scanner input = new Scanner(System.in);

       String[] numbers = input.nextLine().split(" "); /split() делит значения после определённого символа, в нашем случае — пробела

       int sum = 0;

   

       for(int i = 0; i<numbers.length; i++) {

           sum += Integer.parseInt(numbers[i]);

       }

       System.out.println("The sum of the numbers: " + sum);

       //System.out.println(Arrays.toString(numbers));

   }

}

//С циклом while:

import java.util.Scanner;

import java.util.Arrays;

public class MyClass {

   public static void main(String args[]) {

       Scanner input = new Scanner(System.in);

       String[] numbers = input.nextLine().split(" ");

       int sum = 0;

       int i = 0;

 

       while(numbers.length != i) {

              sum += Integer.parseInt(numbers[i]);

              i++;

       }

       System.out.println("The sum of the numbers: " + sum);

       //System.out.println(Arrays.toString(numbers));

   }

}

//С циклом do-while:

import java.util.Scanner;

import java.util.Arrays;

public class MyClass {

   public static void main(String args[]) {

       Scanner input = new Scanner(System.in);

       String[] numbers = input.nextLine().split(" ");

       int sum = 0;

       int i = 0;

       

       do {

           sum += Integer.parseInt(numbers[i]);

           i++;

       } while(numbers.length != i);

       

       System.out.println("The sum of the numbers: " + sum);

       //System.out.println(Arrays.toString(numbers));

   }

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Java, которая вычисляет сумму элементов целочисленного массива с использованием циклов for, while и do-while:

java
public class SumArrayElements { public static void main(String[] args) { int[] array = {1, 2, 3, 4, 5}; // Ваш целочисленный массив int sumFor = 0; for (int i = 0; i < array.length; i++) { sumFor += array[i]; } System.out.println("Сумма элементов (for): " + sumFor); int sumWhile = 0; int j = 0; while (j < array.length) { sumWhile += array[j]; j++; } System.out.println("Сумма элементов (while): " + sumWhile); int sumDoWhile = 0; int k = 0; do { sumDoWhile += array[k]; k++; } while (k < array.length); System.out.println("Сумма элементов (do-while): " + sumDoWhile); } }

Просто замените массив array на ваш собственный массив целых чисел, и программа вычислит сумму его элементов с использованием трех разных видов циклов.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос