Вопрос задан 22.07.2018 в 08:16.
Предмет Информатика.
Спрашивает Авдовченко Маргарита.
(паскаль) Требуется составить программу нахождения количества чисел кратных двум. Любая
последовательность. Помогите пожалуйста!Ответы на вопрос
Отвечает Иванова Александра.
Var a,k:integer;
begin
assign (input, 'input.txt'); reset (input);
assign (output, 'output.txt'); rewrite (output);
k:=0;
while (not Eof(input)) do
begin
readln(a); if (a mod 2 =0)
then
k:=k+1;
end;
writeln(k);
end.
begin
assign (input, 'input.txt'); reset (input);
assign (output, 'output.txt'); rewrite (output);
k:=0;
while (not Eof(input)) do
begin
readln(a); if (a mod 2 =0)
then
k:=k+1;
end;
writeln(k);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Я могу помочь вам с вашим запросом. Вот один из возможных вариантов программы на Паскале, которая находит количество чисел, кратных двум, в любой последовательности:
``` program CountEven; var n, count, x: integer; begin writeln('Введите количество чисел в последовательности:'); readln(n); count := 0; // инициализируем счетчик нулем writeln('Введите числа последовательности:'); for x := 1 to n do // цикл по всем числам begin readln(x); // считываем очередное число if x mod 2 = 0 then // проверяем, кратно ли оно двум count := count + 1; // увеличиваем счетчик на единицу end; writeln('Количество чисел, кратных двум, равно ', count); end. ```
Надеюсь, это было полезно. Если у вас есть еще вопросы, я рад помочь.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
