Информатика, нужна помощь(паскаль или эксель)! F(n)= n3+ n2+1 при n<14F(n)=F(n–1)+2∗n2−3 при
n>13 , кратных 3F(n)=F(n–2)+3∗n+6 при n>13 , не кратных 3 нужен код, ответ и так есть.Ответы на вопрос
Задача решалась с оговоркой о том, чт n3 и n2 означают и
function f(n: integer): integer;
begin
if n < 14 then
f := n * n * n + n * n + 1
else
if n mod 3 = 0 then
f := f(n - 1) + 2 * n * n - 3
else
f := f(n - 2) + 3 * n + 6;
end;
var
n: integer;
begin
readln(n);
writeln(f(n));
end.
Для данной задачи вы можете написать программу на Pascal, чтобы вычислить значение функции F(n) для заданного значения n. Вот пример кода на Pascal:
pascalprogram ComputeF; function F(n: Integer): Integer; begin if n < 14 then F := n * n * n + n * n + 1 else if (n > 13) and (n mod 3 = 0) then F := F(n - 1) + 2 * n * n - 3 else if (n > 13) and (n mod 3 <> 0) then F := F(n - 2) + 3 * n + 6 else F := 0; // Обработка некорректных значений n end; var n, result: Integer; begin writeln('Введите значение n: '); readln(n); result := F(n); writeln('Значение F(', n, ') = ', result); readln; end.
Вы можете скомпилировать и запустить эту программу в своей среде разработки Pascal. Когда она будет запущена, она запросит у вас значение n и вернет значение F(n) согласно вашей задаче.
Если у вас есть конкретные значения n, для которых вы хотите узнать F(n), укажите их, и я могу вычислить результаты для вас.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
