Вопрос задан 25.09.2023 в 07:21. Предмет Информатика. Спрашивает Корецкая Ольга.

Помогите решить задачу на языке Python Анжела – очень занятая девушка, поэтому она старается не

тратить много времени на шоппинг. Однажды у нее закончился крем для лица, и она решила заказать себе первый попавшийся. Ну, почти... "На своей красоте экономить нельзя", – подумала Анжела и решила купить первый попавшийся ей крем, который будет стоить X рублей или дороже. Дан список цен на кремы. Необходимо определить цену крема, который заказала себе Анжела. Формат входных данных С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем, – цены на кремы. Каждое число вводится в отдельной строке. В последней строке вводится целое число X – минимальная стоимость крема.Анжела – очень занятая девушка, поэтому она старается не тратить много времени на шоппинг. Однажды у нее закончился крем для лица, и она решила заказать себе первый попавшийся. Ну, почти... "На своей красоте экономить нельзя", – подумала Анжела и решила купить первый попавшийся ей крем, который будет стоить X рублей или дороже. Дан список цен на кремы. Необходимо определить цену крема, который заказала себе Анжела. Формат входных данных С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем, – цены на кремы. Каждое число вводится в отдельной строке. В последней строке вводится целое число X – минимальная стоимость крема.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Макарова Дайаана.

# вводим цены на кремы

prices = []

price = int(input())

while price != 0:

   prices.append(price)

   price = int(input())

# вводим минимальную стоимость крема

x = int(input())

# находим первый крем, стоимость которого больше или равна x

for price in prices:

   if price >= x:

       print(price)

       break

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи на Python вы можете использовать следующий код:

python
# Создаем список для хранения цен на кремы prices = [] # Вводим цены на кремы до ввода нуля while True: price = int(input("Введите цену на крем (или 0 для завершения): ")) if price == 0: break prices.append(price) # Вводим минимальную стоимость крема x = int(input("Введите минимальную стоимость крема: ")) # Ищем первый крем, который стоит X рублей или дороже found = False for price in prices: if price >= x: print(f"Анжела заказала крем за {price} рублей или дороже.") found = True break if not found: print("Анжела не нашла крем по заданной цене.")

Этот код создает список для хранения цен на кремы, затем с помощью цикла while запрашивает у пользователя цены на кремы, пока не будет введен 0. Затем программа запрашивает минимальную стоимость крема и ищет первый крем в списке, который стоит указанную сумму или дороже. Если такой крем найден, программа выводит его стоимость, иначе выводится сообщение о том, что Анжела не нашла крем по заданной цене.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос