Вопрос задан 24.09.2023 в 15:55. Предмет Информатика. Спрашивает Миронов Рудольф.

Python Сестра Фёдора, Соня ходит в детский сад. На завтрак в саду обычно дают манную или рисовую

кашу. Соня любит рисовую кашу, другие воспитанники любят манную или обе каши. Напишите программу, которая поможет воспитателю определить количество детей, которые предпочитают обе каши. Формат ввода В первых двух строках указывается количество детей, любящих манную и рисовую каши ( n n и m m). Затем идут n n строк — фамилии детей, которые любят манную кашу, и m m строк с фамилиями детей, любящих рисовую кашу. Гарантируется, что в группе нет однофамильцев. Формат вывода Количество воспитанников, которые любят обе каши. Если таких не окажется, в строке вывода нужно написать ''Таких нет''. Пример Ввод 3 3 Иванов Петров Сидоров Иванов Петров Сидоров Вывод 3
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Медведев Роман.

Программа на языке Python для розв'язання задачі:

python

n = int(input())

m = int(input())

man = set()

for i in range(n):

   man.add(input())

rice = set()

for i in range(m):

   rice.add(input())

both = man & rice

if len(both) == 0:

   print("Таких нет")

else:

   print(len(both))

Приклад введення:

3

3

Иванов

Петров

Сидоров

Иванов

Петров

Сидоров

Приклад виведення:

3

Пояснення до програми:

Зчитуємо кількість дітей, які люблять манну та рисову кашу.

Зчитуємо імена дітей, які люблять манну кашу та записуємо їх у множину man.

Зчитуємо імена дітей, які люблять рисову кашу та записуємо їх у множину rice.

Знаходимо спільних елементів у множинах man та rice за допомогою операції перетину множини & та записуємо їх у множину both.

Якщо довжина множини both рівна 0, то виводимо "Таких нет", інакше виводимо довжину множини both.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете решить эту задачу с помощью Python. Вот пример программы:

python
# Ввод количества детей, предпочитающих манную и рисовую кашу n, m = map(int, input().split()) # Создание множеств для детей, предпочитающих манную и рисовую кашу mannaya_kasha_lovers = set() risovaya_kasha_lovers = set() # Считывание фамилий детей, предпочитающих манную кашу for _ in range(n): name = input() mannaya_kasha_lovers.add(name) # Считывание фамилий детей, предпочитающих рисовую кашу for _ in range(m): name = input() risovaya_kasha_lovers.add(name) # Поиск детей, предпочитающих обе каши both_kasha_lovers = mannaya_kasha_lovers.intersection(risovaya_kasha_lovers) # Вывод результата if len(both_kasha_lovers) > 0: print(len(both_kasha_lovers)) else: print("Таких нет")

Пример ввода и вывода из вашего вопроса:

3 3 Иванов Петров Сидоров Иванов Петров Сидоров
3

Этот код сначала считывает количество детей, предпочитающих манную и рисовую кашу, а затем считывает их фамилии и добавляет их в соответствующие множества. Затем он использует метод .intersection() для нахождения детей, которые предпочитают обе каши, и выводит их количество. Если таких детей нет, он выводит "Таких нет".

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос