Вопрос задан 17.09.2023 в 09:56.
Предмет Информатика.
Спрашивает Кузнецов Максим.
Нужна помощь в составлении алгоритма (паскаль АВС) -8 класс. 1 задание: Составьте программу
вычисления количества двухзначных чисел,которые кратны 2 и 3.2 задание: Составьте программу,выводящую на экран все двузначные числа,у которых первая цифра в два раза больше второй.3 задание: Найдите количество двузначных чисел,которые делятся на сумму своих цифр.P.S. Помогите пожалуйста! Очень нужно и срочно! Если можете,то нужно всё сделать; если же нет,то хотя-бы одну или две задачи. Заранее спасибо!!!)))Ответы на вопрос
Отвечает Ерыгин Тимофей.
Var a,b,c:byte;
begin
for c:=1 to 99 do begin
a:=c mod 2; b:=c mod 3;
if (a=0) and (b=0) then write (c);
end;
end.
begin
for c:=1 to 99 do begin
a:=c mod 2; b:=c mod 3;
if (a=0) and (b=0) then write (c);
end;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я помогу вам с составлением алгоритмов на языке программирования Pascal ABC для каждой из задач.
- Вычисление количества двухзначных чисел, которые кратны 2 и 3:
pascalprogram Task1; var count, i: integer; begin count := 0; for i := 10 to 99 do begin if (i mod 2 = 0) and (i mod 3 = 0) then count := count + 1; end; writeln('Количество двухзначных чисел, которые кратны 2 и 3: ', count); end.
- Вывод двузначных чисел, у которых первая цифра в два раза больше второй:
pascalprogram Task2; var i, firstDigit, secondDigit: integer; begin writeln('Двузначные числа, у которых первая цифра в два раза больше второй:'); for i := 10 to 99 do begin firstDigit := i div 10; // Получаем первую цифру secondDigit := i mod 10; // Получаем вторую цифру if firstDigit = 2 * secondDigit then writeln(i); end; end.
- Поиск количества двузначных чисел, которые делятся на сумму своих цифр:
pascalprogram Task3; var count, i, sum, digit1, digit2: integer; begin count := 0; for i := 10 to 99 do begin digit1 := i div 10; // Получаем первую цифру digit2 := i mod 10; // Получаем вторую цифру sum := digit1 + digit2; if (sum <> 0) and (i mod sum = 0) then count := count + 1; end; writeln('Количество двузначных чисел, которые делятся на сумму своих цифр: ', count); end.
Скопируйте каждую из этих программ в среду разработки Pascal ABC и выполните их. Они выполняют требуемые операции для каждой из задач. Удачи вам!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
