Вопрос задан 30.08.2023 в 09:04.
Предмет Информатика.
Спрашивает Курбанов Мурад.
СРОЧНО! Паскаль! 1. Написать программу, которая подсчитывает количество элементов, четных и
оканчивающихся на 6, в массиве целых чисел. Количество элементов массива равно N. Массив заполнить случайными числами в интервале [20,80). Если таких чисел нет, напечатать «Нет». 2. Написать программу, которая подсчитывает количество пар элементов в массиве, в которых каждый элемент равен второму в паре. В массиве 10 элементов, массив заполняется с помощью случайных чисел из интервала (0, 100). Пример работы программы: Входные данные Выходные данные Комментарий 5 5 6 7 7 8 9 2 (первая пара 5 5, вторая – 7 7) 5 5 5 7 7 9 9 4 (первая пара 5 5, вторая 5 5, третья 7 7, четвертая 9 9) 1 2 3 4 5 6 7 8 нет Нет ни одной парыОтветы на вопрос
Отвечает Ковальська Віта.
1) const N = 10;
var a:array[1..N] of integer;
i, k: integer;
begin
k:=0;
for i:=1 to N do
a[i]:= random((80) - 20);
if (a[i] mod 10 = 6) and (a[i] mod 2 = 0) then
k:=k+1;
end;
writeln(k);
2)const N = 10;
var a:array[1..N] of integer;
i, k: integer;
begin
k:=0;
for i:=1 to N do
a[i]:=random(100);
for i:=1 to N-1 do
if a[i] = a[i+1] then
k:=k+1;
writeln(k);
end.
var a:array[1..N] of integer;
i, k: integer;
begin
k:=0;
for i:=1 to N do
a[i]:= random((80) - 20);
if (a[i] mod 10 = 6) and (a[i] mod 2 = 0) then
k:=k+1;
end;
writeln(k);
2)const N = 10;
var a:array[1..N] of integer;
i, k: integer;
begin
k:=0;
for i:=1 to N do
a[i]:=random(100);
for i:=1 to N-1 do
if a[i] = a[i+1] then
k:=k+1;
writeln(k);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для выполнения задачи на языке программирования Pascal, вы можете использовать следующий код:
pascalprogram CountEvenEndingWith6AndPairs; var N, i, countEvenEndingWith6, countPairs: integer; arr: array[1..10] of integer; begin randomize; // Вводим количество элементов массива writeln('Введите количество элементов массива (N): '); readln(N); // Заполняем массив случайными числами в интервале [20, 80) for i := 1 to N do arr[i] := random(60) + 20; // Инициализируем счетчики countEvenEndingWith6 := 0; countPairs := 0; // Перебираем элементы массива for i := 1 to N do begin // Подсчитываем количество элементов, четных и оканчивающихся на 6 if (arr[i] mod 2 = 0) and (arr[i] mod 10 = 6) then countEvenEndingWith6 := countEvenEndingWith6 + 1; // Подсчитываем количество пар элементов, равных друг другу for j := i + 1 to N do begin if arr[i] = arr[j] then countPairs := countPairs + 1; end; end; // Выводим результаты if countEvenEndingWith6 = 0 then writeln('Нет') else writeln('Количество элементов, четных и оканчивающихся на 6: ', countEvenEndingWith6); if countPairs = 0 then writeln('Нет ни одной пары') else writeln('Количество пар элементов, равных друг другу: ', countPairs); end.
Этот код выполняет две задачи: подсчет количества элементов, четных и оканчивающихся на 6, и подсчет количества пар элементов, равных друг другу, в массиве.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
