Вопрос задан 23.08.2023 в 12:21. Предмет Информатика. Спрашивает Процкова Ольга.

Задача на c++ Требуется написать программу, которая определяет цифры исходного четырёхзначного

числа x и выводит их на экран. Формат входных данных Входной поток содержит целое число x (1000≤x≤9999) Формат выходных данных Выведите цифры числа xx по одному в строке, в следующем порядке: тысячи, сотни, десятки и затем единицы.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Каспийская Ольга.
#include <iostream>
using namespace std;

int main()
{
    int a, b;
    cout << "a = ", cin >> a, cout << "\n";
    b = a/1000;
    cout << b << "\n";
    b = a/100 % 10;
    cout << b << "\n";
    b = a % 100 / 10;
    cout << b << "\n";
    b = a % 10;
    cout << b << "\n";
    return 0;
}

Пример:
a = 7052
7
0
5
2
0 0
Отвечает Тюрикова Анфиса.
///////////////////////////////////////////////////////


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Приведенный ниже код демонстрирует, как можно решить данную задачу на C++:

cpp
#include <iostream> int main() { int x; std::cin >> x; // Разделяем число на отдельные цифры int thousands = x / 1000; int hundreds = (x / 100) % 10; int tens = (x / 10) % 10; int ones = x % 10; // Выводим цифры по порядку std::cout << thousands << std::endl; std::cout << hundreds << std::endl; std::cout << tens << std::endl; std::cout << ones << std::endl; return 0; }

Программа читает входное четырёхзначное число, затем разделяет его на тысячи, сотни, десятки и единицы, и выводит каждую цифру на отдельной строке в нужном порядке.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос