Вопрос задан 30.07.2023 в 16:20.
Предмет Информатика.
Спрашивает Катушин Илья.
Напишите программу. С начала суток прошло N секунд (N - целое). Найти количество полных часов,
минут, секунд, прошедших с начала суток. Ввод - 24985 Вывод - 6 ч 56 мин 25 секЯзык с++Ответы на вопрос
Отвечает Лунегова Даша.
#include <iostream>
using namespace std;
int main () {
int n;
cin >> n;
cout << n / 3600 << " ч ";
n -= (n / 3600) * 3600;
cout << n / 60 << " мин ";
n -= (n / 60) * 60;
cout << n << " сек ";
return 0;
}
using namespace std;
int main () {
int n;
cin >> n;
cout << n / 3600 << " ч ";
n -= (n / 3600) * 3600;
cout << n / 60 << " мин ";
n -= (n / 60) * 60;
cout << n << " сек ";
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи можно использовать язык C++. Вот пример программы, которая находит количество полных часов, минут и секунд, прошедших с начала суток, если известно общее количество секунд (N):
cpp#include <iostream>
int main() {
int N;
std::cout << "Введите количество секунд: ";
std::cin >> N;
// Находим количество часов
int hours = N / 3600;
// Остаток секунд после вычитания часов
N %= 3600;
// Находим количество минут
int minutes = N / 60;
// Остаток секунд после вычитания минут
N %= 60;
// Оставшиеся секунды - это N
int seconds = N;
std::cout << "Прошло " << hours << " ч "
<< minutes << " мин " << seconds << " сек" << std::endl;
return 0;
}
С помощью деления и нахождения остатка от деления, программа разбивает общее количество секунд на часы, минуты и секунды. Результат выводится в формате "часы минуты секунды". Если вы введете значение 24985, то получите вывод:
Прошло 6 ч 56 мин 25 сек
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
