Вопрос задан 29.07.2023 в 14:46.
Предмет Информатика.
Спрашивает Бурантаев Руслан.
Для заданного двумерного целочисленного массива mas, являющего квадратной матрицей размерностью n x
n и содержащего n^2 произвольных положительных, отрицательных и равных нулю чисел, составить программу для вычисления: Найти количество минимальных и количество максимальных чисел матрицы. ЯЗЫК ПРОГРАММИРОВАНИЯ С++ ПОМОГИТЕ ААА ПОЖАЛУЙСТАААОтветы на вопрос
Отвечает Фокшек Дмитрий.
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64
#include <array>
#include <iostream>
#include <algorithm>
#include <utility>
using namespace std;
int main()
{
array<array<int, 3>, 3> arr2d { { { 5, 4, 0 },
{-3, 5, 7 },
{ 8, 2,-1 } } };
pair<int, int> maxmin(INT_MAX, 0);
for (const auto& i : arr2d)
{
int curr_min = *min_element(i.cbegin(), i.cend());
int curr_max = *max_element(i.cbegin(), i.cend());
maxmin.first = maxmin.first > curr_min ? curr_min : maxmin.first;
maxmin.second = maxmin.second < curr_max ? curr_max :
maxmin.second;
}
cout << maxmin.first << " " << maxmin.second;
}
#include <array>
#include <iostream>
#include <algorithm>
#include <utility>
using namespace std;
int main()
{
array<array<int, 3>, 3> arr2d { { { 5, 4, 0 },
{-3, 5, 7 },
{ 8, 2,-1 } } };
pair<int, int> maxmin(INT_MAX, 0);
for (const auto& i : arr2d)
{
int curr_min = *min_element(i.cbegin(), i.cend());
int curr_max = *max_element(i.cbegin(), i.cend());
maxmin.first = maxmin.first > curr_min ? curr_min : maxmin.first;
maxmin.second = maxmin.second < curr_max ? curr_max :
maxmin.second;
}
cout << maxmin.first << " " << maxmin.second;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я помогу вам написать программу на C++, которая будет находить количество минимальных и максимальных чисел в заданной квадратной матрице. Вам потребуется пройтись по всем элементам матрицы и подсчитать количество минимальных и максимальных чисел.
Вот пример программы:
cpp#include <iostream>
#include <limits>
const int MAX_SIZE = 100; // Максимальный размер матрицы
int main() {
int mas[MAX_SIZE][MAX_SIZE];
int n;
// Ввод размерности матрицы
std::cout << "Введите размерность матрицы (n): ";
std::cin >> n;
// Ввод элементов матрицы
std::cout << "Введите элементы матрицы:" << std::endl;
for (int i = 0; i < n; ++i) {
for (int j = 0; j < n; ++j) {
std::cin >> mas[i][j];
}
}
// Инициализация переменных для подсчета минимальных и максимальных значений
int minVal = std::numeric_limits<int>::max(); // Максимальное значение int
int maxVal = std::numeric_limits<int>::min(); // Минимальное значение int
int minCount = 0;
int maxCount = 0;
// Поиск минимального и максимального значений в матрице
for (int i = 0; i < n; ++i) {
for (int j = 0; j < n; ++j) {
if (mas[i][j] < minVal) {
minVal = mas[i][j];
minCount = 1;
} else if (mas[i][j] == minVal) {
minCount++;
}
if (mas[i][j] > maxVal) {
maxVal = mas[i][j];
maxCount = 1;
} else if (mas[i][j] == maxVal) {
maxCount++;
}
}
}
// Вывод результатов
std::cout << "Минимальное число: " << minVal << ", количество: " << minCount << std::endl;
std::cout << "Максимальное число: " << maxVal << ", количество: " << maxCount << std::endl;
return 0;
}
Этот код позволяет вам ввести размерность матрицы n и элементы самой матрицы. Затем программа найдет минимальное и максимальное число в матрице и выведет их значения и количество вхождений.
Программа проста и легко читаема. Помните, что максимальный размер матрицы ограничен значением MAX_SIZE, в данном примере равным 100. Если ваша матрица больше этого размера, увеличьте MAX_SIZE в соответствии с вашими потребностями.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 20
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
