Помогите написать на Паскале Дано N пицц Пиццу резать нельзя ! Если распределить пиццы поровну
среди М друзей , то по скольку пицц получит каждый друг и сколько пицц окажутся не распределенными ? Программа получает на вход два натуральных числа N и M , при чем N > M. N не превосходит 10 9 Программа должна вывести два числа- сколько пицц достанется каждому другу и сколько пицц останется не распределенными через пробелОтветы на вопрос
До нельзя просто. div находит целое число от деления, mod — остаток. Путём деления и находим, кто сколько пицц скушает =)
program Pizza2friends;
var N,M:integer;
begin
writeln('Введите количество пицц');
read(N);
writeln('Введите количество друзей');
read(M);
if N > M then
writeln('У каждого друга будет ',N div M,' пицц. Останется ',N mod M,' ничьих пицц.')
else writeln('Пицц должно быть больше, чем друзей');
end.
Для решения этой задачи на Паскале, вы можете использовать следующий код:
pascalprogram PizzaDistribution; var N, M, pizzasPerFriend, remainingPizzas: Integer; begin { Ввод данных } writeln('Введите количество пицц (N): '); readln(N); writeln('Введите количество друзей (M): '); readln(M); { Расчет распределения пицц } pizzasPerFriend := N div M; // Целочисленное деление remainingPizzas := N mod M; // Остаток от деления { Вывод результатов } writeln('Каждому другу достанется пицц: ', pizzasPerFriend); writeln('Пицц останется не распределенными: ', remainingPizzas); end.
Обратите внимание, что в коде используются две операции для расчета распределения:
div: Целочисленное деление (N div M) - определяет, сколько пицц должен получить каждый друг.mod: Остаток от деления (N mod M) - определяет, сколько пицц останется не распределенными.
С помощью этого кода вы сможете ввести количество пицц (N) и количество друзей (M), и программа выдаст ответ о том, сколько пицц получит каждый друг и сколько пицц останется не распределенными.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
