Программа в Паскале Составить программу проверки знания таблицы умножения. Сценарий: компьютер
спрашивает: «Проверим?» (варианты ответов: 0 – «нет», 1 – «да») . Если играющий отвечает «да», то компьютер с помощью генератора случайных чисел задает 2 числа и запрашивает их произведение. После проверки правильности ответа компьютер сообщает «правильно» или «неправильно» и подсчитывает количество правильных ответов и ошибок. Затем компьютер вновь спрашивает: «Проверим?». По окончании работы цикла компьютер выдает статистику игры: сколько всего задано вопросов, количество правильных ответов и число ошибок. Благодарю☺☻Ответы на вопрос
//Язык Pascal
Program multiplication;
Var
code, rightAnswers, mistakes, answersCount, value1, value2, answer: integer;
Begin
Randomize;
code := 1;
rightAnswers := 0;
mistakes := 0;
answersCount := 0;
while code = 1 do
begin
Write('Проверим? ');
Readln(code);
Writeln();
if (code = 1) then
begin
value1 := random(1, 9);
value2 := random(1, 9);
Write(value1, '*', value2, ' = ');
Readln(answer);
if (answer = value1 * value2) then
begin
Writeln('Правильно!');
rightAnswers := rightAnswers + 1;
end
else
begin
Writeln('Неправильно!');
mistakes := mistakes + 1;
end;
answersCount := answersCount + 1;
Writeln();
end;
end;
Writeln('Статистика:');
Writeln('Задано вопросов: ', answersCount);
Writeln('Количество правильных ответов: ', rightAnswers);
Writeln('Число ошибок: ', mistakes);
End.


Добро пожаловать! Вот программа на языке Паскаль, которая реализует ваш сценарий:
pascalprogram ТаблицаУмножения; uses Crt; var Продолжить: Integer; ПравильныеОтветы, Ошибки, ВсегоВопросов: Integer; ПервоеЧисло, ВтороеЧисло, ПравильныйОтвет, ОтветПользователя: Integer; begin Randomize; // Инициализируем генератор случайных чисел Продолжить := 1; ПравильныеОтветы := 0; Ошибки := 0; ВсегоВопросов := 0; while Продолжить = 1 do begin ClrScr; // Очистить экран // Генерируем два случайных числа от 1 до 9 ПервоеЧисло := Random(9) + 1; ВтороеЧисло := Random(9) + 1; // Вычисляем правильный ответ ПравильныйОтвет := ПервоеЧисло * ВтороеЧисло; // Задаем вопрос пользователю WriteLn('Сколько будет ', ПервоеЧисло, ' умножить на ', ВтороеЧисло, '?'); Write('Ответ: '); ReadLn(ОтветПользователя); // Проверяем ответ пользователя if ОтветПользователя = ПравильныйОтвет then begin WriteLn('Правильно!'); ПравильныеОтветы := ПравильныеОтветы + 1; end else begin WriteLn('Неправильно. Правильный ответ: ', ПравильныйОтвет); Ошибки := Ошибки + 1; end; ВсегоВопросов := ВсегоВопросов + 1; // Спрашиваем, продолжать или нет WriteLn('Проверим еще? (0 - нет, 1 - да)'); ReadLn(Продолжить); end; // Выводим статистику WriteLn('--- Статистика ---'); WriteLn('Всего задано вопросов: ', ВсегоВопросов); WriteLn('Правильных ответов: ', ПравильныеОтветы); WriteLn('Ошибок: ', Ошибки); WriteLn('--- Конец игры ---'); end.
Скопируйте этот код в среду разработки Pascal (например, Turbo Pascal, Free Pascal) и выполните его. Программа будет задавать вопросы по таблице умножения до тех пор, пока пользователь не решит завершить игру, введя "0" в ответ на вопрос "Проверим еще?". После окончания игры будет выведена статистика, содержащая общее количество заданных вопросов, количество правильных ответов и количество ошибок.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
