ПОЖАЛУЙСТА 50 БАЛЛОВ paskal abcnet дан массив чисел,вводимый в ручную ,найти значение
максимального элемента и определить ихОтветы на вопрос
PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018
Внимание! Если программа не работает, обновите версию!
begin
var a := ReadArrInteger(ReadInteger('n='));
var max := a.Max;
var i := a.IndexesOf(t -> t = max).ToArray;
Print('Максимум, равный', max, 'у элемента(-ов) номер');
i.Select(t -> t + 1).Println(', ')
end.
Пример
n= 15
-13 16 6 -12 -14 4 -12 -12 12 6 -10 2 16 -7 8
Максимум, равный 16 у элемента(-ов) номер 2, 13
PROGRAM for_znanijacom;
CONST М = 100;
VAR MAS : ARRAY[1..M] OF INTEGER;
I, MAX, K, N : INTEGER;
BEGIN
WRITE('BBEДИTE РАЗМЕР МАССИВА N = ');
READLN(N);
WRITE('BBEДИTE ЭЛЕМЕНТ МАССИВА ');
READLN(MAS[1]);
MAX := MAS[1];
K:=1;
FOR I := 2 TO N DO
BEGIN
WRITE('BBEДИTE ЭЛЕМЕНТ МАССИВА ');
READLN(MAS[I]);
IF MAX<MAS[I] THEN
BEGIN
MAX := MAS[I];
K:= 1
END
ELSE
IF MAX = MAS[I] THEN К := K+1;
END;
WRITELN('MAX =', MAX, 'ЭТИХ ЭЛЕМЕНТОВ', К)
END.
К сожалению, я не могу предоставить "50 баллов" в реальной жизни, так как я всего лишь искусственный интеллект и не имею возможности награждать очки. Однако, я с удовольствием помогу вам написать программу на языке Pascal, которая находит максимальный элемент в массиве чисел, введенных вручную.
Вот пример программы на Pascal, которая решает вашу задачу:
pascalprogram MaxElementInArray; const MAX_SIZE = 100; var arr: array[1..MAX_SIZE] of Integer; n, i, maxElement: Integer; begin WriteLn('Введите количество элементов массива (не более ', MAX_SIZE, '): '); ReadLn(n); if (n <= 0) or (n > MAX_SIZE) then begin WriteLn('Некорректное количество элементов. Завершение программы.'); Exit; end; WriteLn('Введите элементы массива: '); for i := 1 to n do ReadLn(arr[i]); maxElement := arr[1]; // Предполагаем, что первый элемент максимальный for i := 2 to n do begin if arr[i] > maxElement then maxElement := arr[i]; end; WriteLn('Максимальный элемент в массиве: ', maxElement); end.
Пожалуйста, скопируйте этот код в среду разработки Pascal (например, Free Pascal) и выполните программу. Она попросит вас ввести количество элементов массива, а затем элементы самих массивов. После этого она выведет максимальный элемент.
Обратите внимание, что в данной программе ограничение на размер массива установлено на 100 элементов (MAX_SIZE), вы можете изменить это значение в зависимости от ваших потребностей.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
