Очень нужно!!!! На паскале Дан одномерный массив из 15 элементов.Элементы массива положительные
и отрицательные . Найти количество положительных элементов , а отрицательные возвести в квадрат. Вывести количество отрицательных элементов и новый массив.Ответы на вопрос
//PascalABC.NET v3.3 1633
const n = 15;
var arr: array [1..15] of integer;
begin
for var i:=1 to n do
arr[i]:=random(-5,5);
write('Исходный массив: ');
arr.PrintLn(', ');
var countP:=0;
var countN:=0;
for var i:=1 to n do
if arr[i] > 0 then
countP += 1
else
if arr[i] < 0 then
begin
arr[i]:=Sqr(arr[i]);
countN += 1;
end;
writeln('Количество положительных элементов: '+countP);
writeln('Количество отрицательных элементов: '+countN);
write('Новый массив: ');
arr.PrintLn(', ');
end.
Хорошо, я могу помочь вам написать программу на языке Паскаль, которая решит данную задачу. Вот пример кода:
pascalprogram PositiveAndSquared; const N = 15; var arr: array[1..N] of Integer; i, countPositive: Integer; begin // Ввод элементов массива writeln('Введите ', N, ' элементов массива:'); for i := 1 to N do readln(arr[i]); // Инициализация счетчика положительных элементов countPositive := 0; // Обработка массива for i := 1 to N do begin if arr[i] > 0 then countPositive := countPositive + 1 else arr[i] := arr[i] * arr[i]; // Возводим отрицательные элементы в квадрат end; // Вывод количества отрицательных элементов и нового массива writeln('Количество положительных элементов: ', countPositive); writeln('Массив после обработки:'); for i := 1 to N do write(arr[i], ' '); readln; end.
Вы можете скопировать этот код в среду разработки Паскаль и запустить его. Программа запросит у вас ввести 15 элементов массива, затем выведет количество положительных элементов и новый массив, в котором отрицательные элементы будут возведены в квадрат.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
