СРОЧНО ABC Pascal!!!!!!!! Дан одномерный массив А, удалить все четные элементы, вывести на печать
преобразованный массив и число его элементовОтветы на вопрос
Program fantscrin;
const n = 10;
Var a: array [1..n] of integer;
b: array [1..n] of integer;
i,j:integer;
Begin
j:=0;
for i:=1 to n do
a[i]:=random(20);
for i:=1 to n do
write(a[i], ' ');
for i:=1 to n do
if (i mod 2 <> 0) then
begin
j:=j+1;
b[j]:=a[i];
end;
writeln('');
for i:=1 to n do
a[i]:=0;
for i:=1 to j do
a[i]:=b[i];
for i:=1 to j do
write(a[i], ' ');
writeln('');
writeln(j);
End.
Прежде чем написать программу на ABC Pascal для удаления четных элементов из одномерного массива и вывода преобразованного массива, необходимо знать размер массива и его элементы. Также, ABC Pascal обычно использует индексацию с 1.
Допустим, у нас есть массив A размером N и его элементы A[1], A[2], ..., A[N]. Вот как может выглядеть программа для удаления четных элементов:
pascalprogram RemoveEvenElements; const MaxSize = 100; // Максимальный размер массива type TArray = array[1..MaxSize] of Integer; var A: TArray; N, i, j: Integer; procedure RemoveEven(var arr: TArray; var size: Integer); var i, j: Integer; begin j := 0; for i := 1 to size do begin if arr[i] mod 2 <> 0 then // Проверяем, нечетное ли число begin j := j + 1; arr[j] := arr[i]; // Копируем нечетное число в новую позицию end; end; size := j; // Обновляем размер массива end; begin WriteLn('Введите размер массива (не более ', MaxSize, '): '); ReadLn(N); WriteLn('Введите элементы массива: '); for i := 1 to N do ReadLn(A[i]); WriteLn('Исходный массив: '); for i := 1 to N do Write(A[i], ' '); // Удаляем четные элементы RemoveEven(A, N); WriteLn; WriteLn('Преобразованный массив: '); for i := 1 to N do Write(A[i], ' '); WriteLn; WriteLn('Число элементов в преобразованном массиве: ', N); end.
Пользователю нужно будет ввести размер массива и его элементы, после чего программа выведет преобразованный массив без четных элементов и число его элементов.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
