Вопрос задан 17.07.2018 в 23:06.
Предмет Информатика.
Спрашивает Московченко Надежда.
Написать программу, которая вводит n элементов массива и вычисляет сумму первого и максимального
элемента массиваОтветы на вопрос
Отвечает Бахарев Артём.
Случайным образом вводятся целые числа от 0 до 999.
max - максимальный элемент массива
i - цикловая переменная.
var
a : array [1..100] of integer;
max, i, n : integer;
begin
readln (n);
for i := 1 to n do
a [ i ] := random (1000);
max := a [ 1 ];
for i := 2 to n do
if a [ i ] > max then
max := a [ i ];
writeln (max + a [ 1 ])
end.
Отвечает Иванова Полина.
uses crt;
var
a:array [1..1000] of integer;
max,i,k:integer;
begin
write('Введи количество элементов массива: '); read(k);
for i:=1 to k do
begin
a[i]:=random(100)-50;
write(a[i]:4);
end;
writeln;
max:= a[1];
for i:=1 to k do
if a[i]>max then max:=a[i];
writeln('Максимальный элемент: ',max);
writeln ('Сумма первого и максимального элементов: ',max+a[1])
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
