Составить программу вычисления выражения: {3*X, если X ≤ 0Y= {1/X , если X > 0ПОМОГИТЕ
ПОЖАЛУЙСТА, НАДО НА ЗАВТРА!!! Смотреть ответ nedro nedro program p1; var x:integer; y:real; begin WriteLn('Введите число'); ReadLn(x); if x <= 0 then begin y:=3*x; end; if x > 0 then begin y:=1/x; end; WriteLn(y); end.Ответы на вопрос
Программа, которую вы составили, содержит некоторые ошибки, которые я исправлю. Вам следует учитывать правильный синтаксис языка программирования (Pascal, как я предполагаю, посмотрев на код).
Вот исправленный вариант программы на языке Pascal:
pascalprogram p1; var x: integer; y: real; begin WriteLn('Введите число'); ReadLn(x); if x <= 0 then begin y := 3 * x; end else begin y := 1 / x; end; WriteLn(y); end.
Обратите внимание на следующие исправления:
В Pascal используются ключевые слова
program,var,begin,end, и т.д. Не стоит заменять их на символы и пробелы, как в вашем примере.Объявления переменных (например,
xиy) разделяются точкой с запятой.Условие
x <= 0проверяется с помощью оператораif, а условиеx > 0обрабатывается с помощьюelse. Ваша исходная программа содержала два отдельных блокаif.
Теперь программа должна работать правильно. Она запрашивает у пользователя значение x, затем вычисляет y в соответствии с условиями {3*X, если X ≤ 0 и {1/X , если X > 0}, после чего выводит результат на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
