Составить программу, которая считывает элементы двумерного массива и меняет отрицательные элементы
на -1, положительные на 1. Полученную матрицу выводит на экран. (паскаль)Ответы на вопрос
var a: array of array of integer;
i, j, n, m: integer;
begin
read(n, m);
setlength(a, n);
for i := 0 to n - 1 do
begin
setlength(a[i], m);
for j := 0 to m - 1 do
begin
read(a[i][j]);
if (a[i][j] > 0) then
a[i][j] := 1
else if (a[i][j] < 0) then
a[i][j] := -1;
end;
end;
for i := 0 to n - 1 do
begin
for j := 0 to m - 1 do
begin
write(a[i][j]);
write(' ');
end;
writeln();
end;
end.
program znan;
var
x:array [1..1000, 1..1000] of longint;
m,n,i,j:LongInt;
begin
ReadLn(n,m);
for i:=1 to n do
for j:=1 to m do
begin
Read(x[i,j]);
if x[I,j]>=0 then
x[I,j]:=1 else
x[I,j]:=-1;
end;
for i:=1 to n do
for j:=1 to m do
Write(x[i,j], ' ');
end.
Для того чтобы составить программу на языке Паскаль, которая выполняет указанные операции, следуйте приведенному ниже коду:
pascalprogram ChangeMatrixElements; const Rows = 3; // Задайте желаемое количество строк в матрице Cols = 3; // Задайте желаемое количество столбцов в матрице type TMatrix = array[1..Rows, 1..Cols] of Integer; // Процедура для заполнения матрицы с клавиатуры procedure FillMatrix(var matrix: TMatrix); var i, j: Integer; begin for i := 1 to Rows do begin for j := 1 to Cols do begin Write('Введите элемент [', i, ',', j, ']: '); ReadLn(matrix[i, j]); end; end; end; // Процедура для вывода матрицы на экран procedure PrintMatrix(const matrix: TMatrix); var i, j: Integer; begin for i := 1 to Rows do begin for j := 1 to Cols do begin Write(matrix[i, j]:4); end; WriteLn; end; end; // Процедура для замены элементов в матрице procedure ChangeMatrixElements(var matrix: TMatrix); var i, j: Integer; begin for i := 1 to Rows do begin for j := 1 to Cols do begin if matrix[i, j] < 0 then matrix[i, j] := -1 else if matrix[i, j] > 0 then matrix[i, j] := 1; end; end; end; var matrix: TMatrix; begin FillMatrix(matrix); WriteLn('Исходная матрица:'); PrintMatrix(matrix); ChangeMatrixElements(matrix); WriteLn('Матрица после замены:'); PrintMatrix(matrix); end.
Программа позволит вам ввести значения для двумерного массива заданного размера (в данном случае 3x3) с клавиатуры. Затем элементы массива, которые меньше нуля, будут заменены на -1, а элементы, которые больше нуля, будут заменены на 1. Исходная и измененная матрицы будут выведены на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
