Напишите программу на PascalABC - дано слово. Переставьте его последнюю букву на место первой.
Подразумевается при этом, что все последующие буквы будут сдвинуты вправо на одну позицию. Вводится строка, состоящая из одного слова (последовательность строчных латинских букв без пробелов) длиной не более 150 символов.Ответы на вопрос
var
str:string;
s:char;
i:integer;
Begin
readln(str);
s := str[length(str)];
str := str + '0';
for i := length(str)-1 downto 1 do begin
str[i+1] := str[i];
end;
str[1] := s;
delete(str, length(str), 1);
writeln(str);
End.
жду лучший ответ
Для перестановки последней буквы на место первой и сдвига всех остальных букв вправо на одну позицию, можно воспользоваться следующей программой на PascalABC:
pascalprogram RearrangeLetters; const MaxLength = 150; var word: string; len, i: integer; firstLetter, lastLetter: char; begin writeln('Введите слово:'); readln(word); len := length(word); { Проверяем длину слова } if len > MaxLength then begin writeln('Длина слова не должна превышать ', MaxLength, ' символов.'); exit; end; { Получаем первую и последнюю буквы } firstLetter := word[1]; lastLetter := word[len]; { Сдвигаем буквы вправо } for i := len downto 2 do word[i] := word[i - 1]; { Перемещаем последнюю букву на место первой } word[1] := lastLetter; writeln('Результат:'); writeln(word); end.
Программа сначала считывает слово с клавиатуры. Затем она проверяет его длину на предмет превышения максимальной длины (150 символов). После этого она осуществляет перестановку букв в слове, сдвигая все буквы вправо, а затем перемещая последнюю букву на место первой. В результате получается переставленное слово, которое выводится на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
