Напишите программу которая получает с клавиатуры натуральное число которое больше 1 и определяет
простое оно или нет. Для этого нужно делить число на все натуральные числа начиная с 2 пока не получится деление без остатка repeat и untilОтветы на вопрос
program simple_num;
var n:integer;
function simple(num:integer):boolean;
var count, i:integer;
key:boolean;
begin
count := 0;
i := 1;
repeat
if num mod i = 0 then
inc(count);
inc(i);
until (i > num);
if count > 2 then
key := false
else key := true;
simple := key;
end;
begin
writeln('Введите натуральное число больше 1');
readln(n);
if n > 1 then
if simple(n) then
writeln('Число ',n, ' простое')
else writeln('Число ',n, ' непростое')
else writeln('введено число менее 1');
end.
Для написания программы, которая определяет, является ли введенное с клавиатуры число простым или нет, мы можем использовать конструкцию repeat и until. В данном случае, нам нужно будет проверить деление числа на все натуральные числа от 2 до n-1, где n - это введенное число.
Вот программа на языке Pascal, которая выполняет описанную задачу:
pascalprogram PrimeCheck; var num, i: Integer; isPrime: Boolean; begin writeln('Введите натуральное число больше 1: '); readln(num); if num <= 1 then begin writeln('Число должно быть больше 1.'); exit; end; if num = 2 then isPrime := True else begin i := 2; isPrime := True; repeat if num mod i = 0 then isPrime := False; i := i + 1; until (i > Trunc(Sqrt(num))) or (not isPrime); end; if isPrime then writeln(num, ' - простое число.') else writeln(num, ' - составное число.'); end.
Программа запросит у пользователя ввод натурального числа больше 1, а затем определит, является ли оно простым или составным, используя цикл repeat и условную конструкцию if.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
