
Вопрос задан 22.07.2023 в 03:23.
Предмет Информатика.
Спрашивает Терентьев Дмитрий.
Напишите программу на C++, которая проверяет пользователя на знание таблицы умножения. Пользователь
сам вводит два целых однозначных числа. Программа должна задать вопрос («Каков результат умножения первого числа на второе»). Пользователь должен ввести ответ и увидеть на экране правильно он ответил или нет. Если нет – ещё и показать верный результат.

Ответы на вопрос

Отвечает Куанова Аида.
#include <iostream>
using namespace std;
int main(){
int a,b,z;
cin >> a >> b;
cout << "Каков результат умножения первого числа на второе?"
cin>> z;
if (a*b==z) cout << "Правильно!";
else cout << "Неправильно!\n Правильный ответ: " << a * b;
return 0;
}



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Ниже представлена программа на C++, которая проверяет пользователя на знание таблицы умножения:
cpp#include <iostream>
#include <cstdlib>
#include <ctime>
int main() {
// Задаем семя для генерации случайных чисел
std::srand(std::time(0));
// Генерируем два случайных однозначных числа
int firstNumber = std::rand() % 9 + 1;
int secondNumber = std::rand() % 9 + 1;
// Задаем вопрос пользователю
std::cout << "Каков результат умножения " << firstNumber << " на " << secondNumber << "?\n";
// Получаем ответ пользователя
int userAnswer;
std::cin >> userAnswer;
// Вычисляем правильный ответ
int correctAnswer = firstNumber * secondNumber;
// Проверяем ответ пользователя и выводим результат
if (userAnswer == correctAnswer) {
std::cout << "Правильно! Вы знаете таблицу умножения.\n";
} else {
std::cout << "Неправильно! Правильный ответ: " << correctAnswer << ".\n";
}
return 0;
}
Эта программа генерирует два случайных однозначных числа, задает пользователю вопрос о результате их умножения, а затем проверяет правильность ответа и сообщает пользователю результат проверки.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili