Вопрос задан 21.07.2023 в 15:29.
Предмет Информатика.
Спрашивает Онищенко Лёха.
Написать программу, которая вводит массив и заменяет в нем все элементы, которые превышают 7, этим
числом. Вывести массив и кол-во замен. (в Pascal)Ответы на вопрос
Отвечает Величко Анастасия.
const
n=10;
var
a : array [1..n] of integer;
i,k,m : integer;
begin
randomize;
k:=0;
writeln('введите число, на которое заменять элементы: ');
read(m);
writeln('Массив:');
for i:=1 to n do
begin
a[i]:=random(10)+1;
write(a[i]:4);
end;
writeln;
for i:=1 to n do
if (a[i]>7) then
a[i]:=m;
writeln('изменённый массив:');
for i:=1 to n do
write(a[i]:4);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Pascal, которая выполняет указанные вами действия:
pascalprogram ReplaceElements; const MAX_SIZE = 100; type IntArray = array[1..MAX_SIZE] of Integer; var arr: IntArray; size, i, replacements: Integer; procedure ReadArray(var arr: IntArray; size: Integer); var i: Integer; begin for i := 1 to size do begin Write('Введите элемент ', i, ': '); ReadLn(arr[i]); end; end; procedure ReplaceElementsGreaterThanSeven(var arr: IntArray; size: Integer; var replacements: Integer); var i: Integer; begin replacements := 0; for i := 1 to size do begin if arr[i] > 7 then begin arr[i] := 7; Inc(replacements); end; end; end; procedure PrintArray(const arr: IntArray; size: Integer); var i: Integer; begin for i := 1 to size do Write(arr[i], ' '); WriteLn; end; begin Write('Введите размер массива (не более ', MAX_SIZE, '): '); ReadLn(size); if (size < 1) or (size > MAX_SIZE) then begin WriteLn('Некорректный размер массива.'); Exit; end; ReadArray(arr, size); ReplaceElementsGreaterThanSeven(arr, size, replacements); WriteLn('Исходный массив:'); PrintArray(arr, size); WriteLn('Количество замен: ', replacements); end.
Программа позволяет пользователю ввести размер массива и его элементы. Затем она заменяет все элементы, которые превышают 7, значением 7, подсчитывает количество замен и выводит измененный массив и количество замен на экран.
Похожие вопросы
Информатика 80
Информатика 95
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
