Вопрос задан 21.07.2023 в 11:24.
Предмет Информатика.
Спрашивает Тишков Стас.
Составьте программу (Паскаль) вычисления суммы квадратов чисел от 10 до 100, делящихся без остатка
на 7 совсем не знаю, как это делать :с, люди добрые помогитеОтветы на вопрос
Отвечает Саванович Юра.
var
s,k: integer;
begin
s:= 0;
for k:=10 to 100 do
if k mod 7 = 0 then
s:= s+sqr (k);
writeln (s);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я помогу вам составить программу на языке Паскаль для вычисления суммы квадратов чисел от 10 до 100, которые делятся без остатка на 7. Ниже представлен код:
pascalprogram SumOfSquares; var num, sum: integer; begin sum := 0; for num := 10 to 100 do begin if num mod 7 = 0 then begin sum := sum + num * num; end; end; writeln('Сумма квадратов чисел от 10 до 100, делящихся на 7 без остатка: ', sum); end.
Обратите внимание на оператор mod, который вычисляет остаток от деления числа на 7. Если остаток равен нулю, то число делится на 7 без остатка.
Программа просто перебирает числа от 10 до 100 и, если число делится на 7 без остатка, добавляет его квадрат к переменной sum. В результате будет выведена сумма квадратов всех таких чисел.
Похожие вопросы
Информатика 81
Информатика 98
Информатика 91
Информатика 60
Информатика 23
Информатика 16
Информатика 46
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
