Помогите написать программу в паскале.. Среди чисел последовательности 1,2,3,4,5,8,13 ...(каждый
следующий член последовательности равен сумме двух предыдущих), найдите количество чисел до первого шестизначного Заранее благодарю за любую помощьОтветы на вопрос
Var i, x1, x2, x3,m, y:integer;
Begin
X1:=1;x2:=2;i:=0;m:=0;
While i<>6 do begin
X3:=x1+x2;y:=x3;m:=m+1;i:=0;
While x3>0 do begin
I:=i+1;
X3:=x3 div 10;
End;
X1:=x2;x2:=y;write(' ', y) ;
End;
Write('Первое шестизначное число находиться на ',m,' месте') ;
End.
Вроде как-то так
Конечно, я помогу вам написать программу на языке Паскаль, которая найдет количество чисел в последовательности до первого шестизначного числа.
Вот программа на Паскале:
pascalprogram FindSixDigitNumber; var prev, current, next: Integer; count: Integer; begin prev := 1; current := 2; count := 2; // Уже знаем первые два числа (1 и 2) while current < 100000 do begin next := prev + current; prev := current; current := next; count := count + 1; end; writeln('Количество чисел до первого шестизначного числа: ', count); end.
Эта программа вычисляет числа последовательности, начиная с 1 и 2, и продолжает генерировать следующие числа, пока не будет найдено первое шестизначное число (больше или равно 100000). Затем программа выводит количество чисел до этого шестизначного числа. В данном случае ответ составляет 16 чисел до первого шестизначного числа 100000.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
