Вопрос задан 19.07.2023 в 20:57. Предмет Информатика. Спрашивает Байдацький Денис.

Помогите!!!Срочно!!Python. составьте программу которая определяет количество

положительных,отрицательных чисел и нулей среди введенных чисел​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Наумова Инна.

p, o, n, counter = 0,0,0,0

print('Вводите 10 чисел по очереди')

while counter <= 10:

   counter += 1

   a = int(input())

   if a > 0:

       p += 1

   elif a < 0:

       o += 1;

   else:

       n += 1;

print('Положительные: ',p)

print('Отрицательные: ',o)

print('Нули: ',n)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот простая программа на Python, которая позволяет определить количество положительных, отрицательных чисел и нулей среди введенных пользователем чисел:

python
def count_numbers(): positive_count = 0 negative_count = 0 zero_count = 0 while True: try: num = float(input("Введите число (или 0 для выхода): ")) if num > 0: positive_count += 1 elif num < 0: negative_count += 1 else: zero_count += 1 except ValueError: print("Некорректный ввод числа. Пожалуйста, попробуйте еще раз.") continue if num == 0: break print(f"Количество положительных чисел: {positive_count}") print(f"Количество отрицательных чисел: {negative_count}") print(f"Количество нулей: {zero_count}") count_numbers()

Эта программа бесконечно запрашивает ввод чисел до тех пор, пока не будет введен ноль, что приведет к завершению программы. Ввод некорректных значений (не чисел) будет обработан, и программа попросит пользователя ввести число еще раз. После завершения ввода будет выведена информация о количестве положительных, отрицательных чисел и нулей среди введенных.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос